HDU_2602_背包问题

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 2  31).
 

Sample Input

       
       
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

       
       
14
 





#include <iostream>
#include <cstdio>
#include <cstring>
#define MAX_N 1005
#define MAX_V 1005
using namespace std;
long long  w[MAX_N];
long long  v[MAX_N];
long long  dp[MAX_N][MAX_V];
long long  V;
long long  n;
long long  t,k;
int  main()
{
    //freopen("±³°üF.txt", "r",stdin);
    scanf("%d",&t);
    k=t;
    while(t--)
    {
        scanf("%d %d",&n,&V);
        for(long long  i=0;i<n;i++)
        {
            scanf("%ld",v+i);
        }
        for(long long  i=0;i<n;i++)
        {
            scanf("%ld",w+i);
        }

        void solve();
        solve();
    }
}
void solve()
{
    memset(dp,0,sizeof(dp));

    for(int  i=0;i<n;i++)
    {
        for(int  j=0;j<=V;j++)
        {
            if(w[i]>j)
            {
                dp[i+1][j]=dp[i][j];
            }
            else{
                dp[i+1][j]=max(dp[i][j],dp[i][j-w[i]]+v[i]);
            }
        }
    }
    printf("%ld\n",dp[n][V]);
}


这个题还可以采用01滚动的方式
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define MAX_W 1005
#define MAX_N 1005
int dp[MAX_W+1];
int w[MAX_N];
int v[MAX_N];
int n;
int V;
int main()
{

    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&V);
        for(int i=0;i<n;i++)
        {
            scanf("%d",v+i);
        }
         for(int i=0;i<n;i++)
        {
            scanf("%d",w+i);
        }
        void solve();
        solve();
    }
}
void solve()
{
    memset(dp,0,sizeof(dp));
    for(int i=0;i<n;i++)
    {
        for(int j=V;j>=w[i];j--)
        {
            dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        }
    }
    printf("%d\n",dp[V]);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值