用VS2010自带的Library Package Manager安装EFCodeFirst出现“无法加载一个或多个请求的类型”错误的解决方法

最近在学习ASP.NET MVC 3.0的时候需要安装EFCodeFirst,按照教程的说明点击“工具”菜单下的“Library Package Manager”子菜单下的“Add Library Package Reference”菜单选项,却出现了“无法加载一个或多个请求的类型”的错误。上网查了一下,试图点击“Library Package Manager”子菜单下的“Package Manager Console“进行安装时,却发现点击之后“Package Manager Console“和“Package Manager Settings”子菜单项都变成了灰色,仍然无法安装。

 

解决方法:从http://www.microsoft.com/downloads/zh-cn/details.aspx?FamilyID=60cb5b6c-6532-45e0-ab0f-a94ae9ababf5下载安装包,安装Windows PowerShell 2.0 和 Windows Remote Management (WinRM) 2.0,问题即解决。

 

如果后续还有问题,可以参考这篇博文http://blog.csdn.net/yangzhencheng_001/article/details/6684853

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页