HDU4902:Nice boat(线段树lazy)

Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

Let us continue our story, z*p(actually you) defeat the 'MengMengDa' party's leader, and the 'MengMengDa' party dissolved. z*p becomes the most famous guy among the princess's knight party. 

One day, the people in the party find that z*p has died. As what he has done in the past, people just say 'Oh, what a nice boat' and don't care about why he died.

Since then, many people died but no one knows why and everyone is fine about that. Meanwhile, the devil sends her knight to challenge you with Algorithm contest.

There is a hard data structure problem in the contest:

There are n numbers a_1,a_2,...,a_n on a line, everytime you can change every number in a segment [l,r] into a number x(type 1), or change every number a_i in a segment [l,r] which is bigger than x to gcd(a_i,x) (type 2).

You should output the final sequence.
 

Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains a integers n.
The next line contains n integers a_1,a_2,...,a_n separated by a single space.
The next line contains an integer Q, denoting the number of the operations.
The next Q line contains 4 integers t,l,r,x. t denotes the operation type.

T<=2,n,Q<=100000
a_i,x >=0
a_i,x is in the range of int32(C++)
 

Output
For each test case, output a line with n integers separated by a single space representing the final sequence.
Please output a single more space after end of the sequence
 

Sample Input
  
  
1 10 16807 282475249 1622650073 984943658 1144108930 470211272 101027544 1457850878 1458777923 2007237709 10 1 3 6 74243042 2 4 8 16531729 1 3 4 1474833169 2 1 8 1131570933 2 7 9 1505795335 2 3 7 101929267 1 4 10 1624379149 2 2 8 2110010672 2 6 7 156091745 1 2 5 937186357
 

Sample Output
  
  
16807 937186357 937186357 937186357 937186357 1 1 1624379149 1624379149 1624379149
又是一道线段树,比上次的多校那个要容易一点
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define LL 100005
#define ll __int64
#define lson 2*i
#define rson 2*i+1
#define ls l,mid,2*i
#define rs mid+1,r,2*i+1
struct node
{
    int l,r;
    ll num,maxn;
} a[LL<<2];
int n,m;
ll gcd(ll a,ll b)
{
    if(!b) return a;
    else return gcd(b,a%b);
}

void PushUp(int i)
{
    a[i].num=(a[lson].num==a[rson].num)?a[lson].num:-1;
    a[i].maxn=max(a[lson].maxn,a[rson].maxn);
}

void PushDown(int i)
{
    if(a[i].num>-1)
    {
        a[lson].num = a[rson].num = a[i].num;
        a[lson].maxn = a[rson].maxn = a[i].maxn;
    }
}
void init(int l,int r,int i)
{
    a[i].l = l;
    a[i].r = r;
    if(l == r)
        scanf("%I64d",&a[i].num);
    else
    {
        int mid = (l+r)>>1;
        init(ls);
        init(rs);
        PushUp(i);
    }
}

void change1(int L,int R,ll x,int i)
{
    int l = a[i].l,r = a[i].r;
    if(L<=l && r<=R)
    {
        a[i].num = x;
        a[i].maxn = x;
    }
    else
    {
        int mid = (l+r)>>1;
        PushDown(i);
        if(mid>=R)
            change1(L,R,x,lson);
        else if(mid<L)
            change1(L,R,x,rson);
        else
        {
            change1(L,R,x,lson);
            change1(L,R,x,rson);
        }
        PushUp(i);
    }
}

void change2(int L,int R,ll x,int i)
{
    int l = a[i].l,r = a[i].r;
    if(a[i].maxn<=x) return ;
    if(L<=l && r<=R)
    {
        if(a[i].num>-1)
        {
            a[i].num = gcd(a[i].num,x);
            a[i].maxn = a[i].num;
        }
        else
        {
            PushDown(i);
            change2(L,R,x,lson);
            change2(L,R,x,rson);
            PushUp(i);
        }
    }
    else
    {
        int mid = (l+r)>>1;
        PushDown(i);
        if(mid>=R)
            change2(L,R,x,lson);
        else if(mid<L)
            change2(L,R,x,rson);
        else
        {
            change2(L,R,x,lson);
            change2(L,R,x,rson);
        }
          PushUp(i);
    }

}

void print(int l,int r,int i)
{
    if(a[i].num>-1)
        for(int j = l; j<=r; j++)
            printf("%I64d ",a[i].num);
    else
    {
        int mid = (l+r)>>1;
        print(ls);
        print(rs);
    }
}

int main()
{
    int t,l,r,cas;
    __int64 x;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        init(1,n,1);
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d%d%d%I64d",&cas,&l,&r,&x);
            if(cas == 1) change1(l,r,x,1);
            else change2(l,r,x,1);
        }
        print(1,n,1);
        printf("\n");
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值