POJ2305:Basic remains

Description

Given a base b and two non-negative base b integers p and m, compute p mod m and print the result as a base b integer. p mod m is defined as the smallest non-negative integer k such that p = a*m + k for some integer a.

Input

Input consists of a number of cases. Each case is represented by a line containing three unsigned integers. The first, b, is a decimal number between 2 and 10. The second, p, contains up to 1000 digits between 0 and b-1. The third, m, contains up to 9 digits between 0 and b-1. The last case is followed by a line containing 0.

Output

For each test case, print a line giving p mod m as a base-b integer.

Sample Input

2 1100 101
10 123456789123456789123456789 1000
0

Sample Output

10
789
 
 
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

void print(int r,int b)
{
    if(r>0)
    {
        print(r/b,b);
        printf("%d",r%b);
    }
}
int main()
{
    char p[10000],M[10];
    int n,i,m,r;
    while(~scanf("%d",&n))
    {
        if(!n)
            return 0;
        scanf("%s%s",p,M);
        int len = strlen(p);
        m = strtol(M,0,n);
        r = 0;
        for(i = 0; i<len; i++)
        {
            r = r*n+p[i]%48;
            r%=m;
        }
        print(r,n);
        puts(r?"":"0");
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值