HDU1086:You can Solve a Geometry Problem too(线段相交模板)

Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point.  
 

Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.  
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the number of intersections, and one line one case.
 

Sample Input
  
  
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0
 

Sample Output
  
  
1 3
 


 

这道题要用到线段相交的知识,虽然线段相交咋看听容易,但真正要把代码写出来还是不简单的

反正我在百度搜索的时候要用到两个知识点,建议有兴趣的同学可以去认真的理解下

 

#include <stdio.h>
#include <iostream>
#include <math.h>
#include <algorithm>
using namespace std;

struct point
{
    double x,y;
};
point a[105][2];

double fan(double x,double y)
{
    return x>y?x:y;
}

double fin(double c,double d)
{
    return c<d?c:d;
}

double cnt(point a,point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

int is(point a,point b,point c,point d)//线段相交模板
{
    if(a.x==b.x&&c.x==d.x)
    {
        return 0;
    }
    if(a.x==b.x&&c.x!=d.x)
    {
        double m1=a.x;
        double m2=(a.x-c.x)*(d.y-c.y)/(d.x-c.x)+c.y;
        if(m1<=fan(a.x,b.x)&&m1>=fin(a.x,b.x)&&m2>=fin(a.y,b.y)&&m2<=fan(a.y,b.y)&&m1<=fan(c.x,d.x)&&m1>=fin(c.x,d.x)&&m2>=fin(c.y,d.y)&&m2<=fan(c.y,d.y))
            return 1;
    }
    if(c.x==d.x&&a.x!=b.x)
    {
        double m1=c.x;
        double m2=a.y+(b.y-a.y)*(c.x-a.x)/(b.x-a.x);
        if(m1<=fan(a.x,b.x)&&m1>=fin(a.x,b.x)&&m2>=fin(a.y,b.y)&&m2<=fan(a.y,b.y)&&m1<=fan(c.x,d.x)&&m1>=fin(c.x,d.x)&&m2>=fin(c.y,d.y)&&m2<=fan(c.y,d.y))
            return 1;
    }
    double k1=(b.y-a.y)/(b.x-a.x);
    double k2=(d.y-c.y)/(d.x-c.x);
    double m1,m2,x,y;
    if(k1==k2)  return 0;
    else
    {
        m1=a.y-k1*a.x;
        m2=c.y-k2*c.x;
        x=(m1-m2)/(k2-k1);
        y=k1*x+m1;
        if(x<=fan(a.x,b.x)&&x>=fin(a.x,b.x)&&y>=fin(a.y,b.y)&&y<=fan(a.y,b.y)&&x<=fan(c.x,d.x)&&x>=fin(c.x,d.x)&&y>=fin(c.y,d.y)&&y<=fan(c.y,d.y))
            return 1;
    }
    return 0;
}

int main()
{
    int cas = 1;
    int n,i,j;
    while(~scanf("%d",&n),n)
    {
        int cnt = 0;
        for(i = 0;i<n;i++)
        scanf("%lf%lf%lf%lf",&a[i][0].x,&a[i][0].y,&a[i][1].x,&a[i][1].y);
        for(i = 0;i<n;i++)
        {
            for(j = i+1;j<n;j++)
            {
                if(is(a[i][0],a[i][1],a[j][0],a[j][1]))
                cnt++;
            }
        }
        printf("%d\n",cnt);
    }

    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值