找不到指定版本的API,failed to find Build Tools revision 23.0.0 rc2

Error:failed to find Build Tools revision 23.0.0 rc2 Install Build Tools 23.0.0 rc2 and sync project

错误的大概意思就是说,找不到找不到指定版本的构建工具,安装之后再同步项目。


出现该问题是因为有两种情况:


一、本地没有指定的API版本

原因:没有指定API。

解决方法:

1.直接安装,点击提示信息就会自动下载并安装 

2.手动更改build.gradle,将版本号改为本地存在的即可


二、本地没有指定的API版本,并且该版无法下载

描述:23.0.0 rc2——后面跟RC的是Release Candidate的缩写,意思是侯选版本,等正式版本发布之后,侯选版本将被淘汰了,导致无法下载

原因:没有指定API,并且该API无法下载。怎么办呢?

解决方法:

1.手动更改build.gradle,将版本号改为本地存在的即可


看到这里,说明你遇到第二个,无法下载RC版本的问题了。


接下来将带你如何修复这个问题。


如果图片看不清楚,图片是1080P的图片,放大网页看得更清楚。


修改指定的本地的build.gradle,注意是在app下面的build.gradle




查看存在的版本号最简便的方法就是在File-Project Structure-Modules-Properties中的Build Tools Version。




需要注意的是:直接在这里设置貌似不对,只能手动修改build.grale文件,我这里改为当前最新的版本23.0.3



之后便是等待build



我这里遇到一个gradle版本问题,如果没有遇到请跳过这里,

1、我直接只需要点击修复就可以了

2、找到gradle->wrapper->gradle-wrapper.properties(修改为正确的版本即可【如果不知道,那就新建一个项目,拷贝一份就行了】)




完成之后工程的gradle也就配置完成了

阅读更多
文章标签: androidstudio gradle
个人分类: Android Studio
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭