计蒜客 ACM-ICPC 2018 南京赛区网络预赛 AC Challenge(状态压缩)

Dlsj is competing in a contest with n (0 < n \le 20)n(0<n≤20) problems. And he knows the answer of all of these problems.

However, he can submit ii-th problem if and only if he has submitted (and passed, of course) s_isi​ problems, the p_{i, 1}pi,1​-th, p_{i, 2}pi,2​-th, ......, p_{i, s_i}pi,si​​-th problem before.(0 < p_{i, j} \le n,0 < j \le s_i,0 < i \le n)(0<pi,j​≤n,0<j≤si​,0<i≤n) After the submit of a problem, he has to wait for one minute, or cooling down time to submit another problem. As soon as the cooling down phase ended, he will submit his solution (and get "Accepted" of course) for the next problem he selected to solve or he will say that the contest is too easy and leave the arena.

"I wonder if I can leave the contest arena when the problems are too easy for me."
"No problem."
—— CCF NOI Problem set

If he submits and passes the ii-th problem on tt-th minute(or the tt-th problem he solve is problem ii), he can get t \times a_i + b_it×ai​+bi​ points. (|a_i|, |b_i| \le 10^9)(∣ai​∣,∣bi​∣≤109).

Your task is to calculate the maximum number of points he can get in the contest.

Input

The first line of input contains an integer, nn, which is the number of problems.

Then follows nn lines, the ii-th line contains s_i + 3si​+3 integers, a_i,b_i,s_i,p_1,p_2,...,p_{s_i}ai​,bi​,si​,p1​,p2​,...,psi​​as described in the description above.

Output

Output one line with one integer, the maximum number of points he can get in the contest.

Hint

In the first sample.

On the first minute, Dlsj submitted the first problem, and get 1 \times 5 + 6 = 111×5+6=11 points.

On the second minute, Dlsj submitted the second problem, and get 2 \times 4 + 5 = 132×4+5=13 points.

On the third minute, Dlsj submitted the third problem, and get 3 \times 3 + 4 = 133×3+4=13 points.

On the forth minute, Dlsj submitted the forth problem, and get 4 \times 2 + 3 = 114×2+3=11 points.

On the fifth minute, Dlsj submitted the fifth problem, and get 5 \times 1 + 2 = 75×1+2=7 points.

So he can get 11+13+13+11+7=5511+13+13+11+7=55 points in total.

In the second sample, you should note that he doesn't have to solve all the problems.

样例输入1复制

5
5 6 0
4 5 1 1
3 4 1 2
2 3 1 3
1 2 1 4

样例输出1复制

55

样例输入2复制

1
-100 0 0

样例输出2复制

0
/*此题的意思是给出n个题,依次给出1到n题的a,b,s值,用i表示第几个题,
s表示要解决第i题先解决s个前置问题,如先解决p1,p2...ps个题之后才能解决第i题

例如:
3
5 6 0
1 1 0
1 1 1 2
第3行“1 1 2”表示要解决第3个问题,需要先解决1个前置问题,也就是第2个问题
根据题意选择适当的解决顺序使分数值最高
*/
#include<iostream>
#include<queue>
#include<cstdio>
#include<string.h>
using namespace std;
const int MAXN=1<<21;
const long long INF=1e18;
long long dp[MAXN];
long long qian[MAXN],a[MAXN],b[MAXN];
long long count(long long x){
    long long num=0;
    for (int j=0;j<25;j++)
        if (x&(1<<j)) num++;
    return num;
}

int main(){
    int N,M;
    scanf("%d",&N);
    for(int i=1;i<=N;i++){
        scanf("%lld%lld%d",&a[i],&b[i],&M);
        qian[i]=0;
        for(int j=0;j<M;j++){
            int k;
            scanf("%d",&k);
            qian[i]+=(1<<(k-1));//做出这道题前,要先做哪些题,用二进制位表示,1 代表需要做
        }
    }
    long long ans=0;
    for(int i=0;i<=(1<<N)-1;i++)
        dp[i]=-INF;
    dp[0]=0;
    for(int i=1;i<=(1<<N)-1;i++){//位数
        for(int j=0;j<N;j++){
            if(i&(1<<j))//枚举子集
            {
                int u=i-(1<<j);
                if((u&qian[j+1])==qian[j+1])//如果满足转移要求,则转移
                {
                    long long w=dp[u]+count(i)*a[j+1]+b[j+1];
                    dp[i]=max(dp[i],w);
                    ans=max(ans,dp[i]);
                }
            }
        }
    }
    printf("%lld\n",ans);

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值