ZOJ-3168 字符串

3168:将给定的字符串排列为先Z再O再J再7,然后是剩余部分。

Sample Input

t7ZJ7OhO7B7O7irZtOhZdayJ77

Sample Output

ZZZOOOOJJ7777777thBirthday

思路:实际上没有排序,先统计,再过滤了一次。

#include<iostream>
using namespace std;
#include<string.h>

char str[1001];

int main()
{
int countZ;
int countO;
int countJ;
int count7;

while(cin>>str)
{
countZ = 0;
countO = 0;
countJ = 0;
count7 = 0;
for(int i=0;i<strlen(str);i++)
{
if(str[i]=='Z')
countZ++;
else if(str[i]=='O')
countO++;
else if(str[i]=='J')
countJ++;
else if(str[i]=='7')
count7++;
}
for(int i = 0;i<countZ;i++)
cout<<'Z';
for(int i = 0;i<countO;i++)
cout<<'O';
for(int i = 0;i<countJ;i++)
cout<<'J';
for(int i = 0;i<count7;i++)
cout<<'7';
for(int i=0;i<strlen(str);i++)
{
if(!(str[i]=='Z'||str[i]=='O'||str[i]=='J'||str[i]=='7'))
cout<<str[i];
}
cout<<endl;
}

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值