Problem1004


/**
* Description
* Larry graduated this year and finally has a job.
* He's making a lot of money, but somehow never seems to have enough.
* Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems.
* The first step is to figure out what's been going on with his money.
* Larry has his bank account statements and wants to see how much money he has.
* Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
*
* Input
* The input will be twelve lines.
* Each line will contain the closing balance of his bank account for a particular month.
* Each number will be positive and displayed to the penny. No dollar sign will be included.
*
* Output
* The output will be a single number,
* the average (mean) of the closing balances for the twelve months.
* It will be rounded to the nearest penny, preceded immediately by a dollar sign,
* and followed by the end-of-line. There will be no other spaces or characters in the output.
*
* Sample Input
* 100.00
* 489.12
* 12454.12
* 1234.10
* 823.05
* 109.20
* 5.27
* 1542.25
* 839.18
* 83.99
* 1295.01
* 1.75
*
* Sample Output
* $1581.42
*/
package acm;

import java.io.BufferedReader;
import java.io.InputStreamReader;

public class Problem1004 {
public static void main(String[] args) {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
double sum = 0.00;
//计算总额
for (int i = 0; i < 12; i++) {
try {
sum += Double.parseDouble(br.readLine());
} catch (Exception e) {
e.printStackTrace();
}
}
//计算平均数
double avg = sum/12;
//四舍五入到两位小数
if(avg%0.01>0.0045){
avg+=0.01;
}
//乘以100将头两位小数纳入,再除以100将结果精确到两位小数
avg*=100;
avg-=(avg%1);
avg/=100;
System.out.println("$"+avg);
}
}


题目:有个小子想算算自己银行账户一年每个月平均能剩多少钱
里面的精确到小数后两位可把我的懒脑累惨了,后来才发现原来*100再/100就能完成这个工作 :wink:
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值