Java compiler level does not match the version of the installed Java project facet等常见编译器问题

1、Building workspace has encountered a problem 

最近用MyEclipse10在做一个项目时,MyEclipse出现这个故障,Building workspace has encountered a problem.Error occured during the build. 经过尝试,其他方法无效,


下面这个方法完美解决了这个问题。

(1)关闭当前工作空间,即关闭MyEclipse.

(2)找到工作空间下的

"/.metadata/.plugins/org.eclipse.core.runtime/.settings/com.genuitec.eclipse.ast.deploy.core.prefs”

该文件内容如下:

 

 

(3)删除刚才找到的com.genuitec.eclipse.ast.deploy.core.prefs 文件。

(4)重启MyEclipse,故障解除!

提示:com.genuitec.eclipse.ast.deploy.core.prefs在这个文件中存储了一些部署项目的信息。

删了这个部署的项目的信息就没有错误了。

2、Java compiler level does not match the version of the installed Java project facet错误的解决

因工作的关系,Eclipse开发的Java项目拷来拷去,有时候会报一个很奇怪的错误。明明源码一模一样,为什么项目复制到另一台机器上,就会报“java compiler level does not match the version of the installed java project facet”错误呢?

如图所示:


其实要解决也很简单,在资源管理器下,找到项目所在的目录,在.settings子目录里面,用文本编辑器打开org.eclipse.wst.common.project.facet.core.xml配置文件,如图所示:



修改红色画线部分,让它与项目的编译器版本设置保持一致即可。

要查看项目的编译器版本设置,在Eclipse环境中,鼠标右键选择项目,点击Properties,选择Java Compiler,可以在窗口右边看到编译器版本,如图所示:

 

3、Description Resource Path Location Type ...project facets version

project 编译问题 

1、properties->project Facets->修改右侧的version  保持一致 

2、window->preferences->java->Compiler->设置右侧的Compiler compliance level 

3、window->preferences->java->Installed JREs->设置或者选择右侧的Installed JREs 

以上三处的jdk版本要保持一致,才能编译通过

阅读更多
个人分类: eclipse问题
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭