AYITACM2016省赛第二周(dp+其他)B-做作业(贪心)

Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 
 

Output

For each test case, you should output the smallest total reduced score, one line per test case. 
 

Sample Input

    
    
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output

    
    
0 3 5
分析:

小明刚参加完比赛,有很多作业需要去做,老师都给他了一个期限,如果没有完成会有相应的扣分项,现在就是找到最好的完成作业的办法,使小明的扣分降到最少!

定义一个天数的数组,标记这一天有没有作业要做,后边的作业可以用前边的时间去做,实在没有时间就不得不扣分了!

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct zuoye
{
    int x,y; //x为截止期限,y为分值
} a[25100];
int cmp(zuoye A,zuoye B)
{
    return A.y>B.y;
}
int main()
{
    int m,n,i,j,k,t,s,v[1100];
    scanf("%d",&n);
    while(n--)
    {
        memset(v,0,sizeof(v));
        scanf("%d",&m);
        for(i=0; i<m; i++)   //输入作业的截止期限
            scanf("%d",&a[i].x);
        for(i=0; i<m; i++) //输入作业的扣分值
            scanf("%d",&a[i].y);
        sort(a,a+m,cmp); 
        s=0;
        for(i=0; i<m; i++)
        {
            k=0;
           for(j=a[i].x;j>0;j--) //注意没有第0天
            if(!v[j])  //如果第j天没有被占用
           {
               v[j]=1; //用第j天来写第i个作业
               k=1;
               break;
           }
           if(k==0) //如果没有找到时间写这个作业,就被扣分
            s+=a[i].y;
        }
        printf("%d\n",s);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值