题目1370:数组中出现次数超过一半的数字
时间限制:1 秒内存限制:32 兆特殊判题:否提交:2844解决:846
题目描述:
数组中有一个数字出现的次数超过数组长度的一半,请找出这个数字。例如输入一个长度为9的数组{1,2,3,2,2,2,5,4,2}。由于数字2在数组中出现了5次,超过数组长度的一半,因此输出2。
输入:
每个测试案例包括2行:
第一行输入一个整数n(1<=n<=100000),表示数组中元素的个数。
第二行输入n个整数,表示数组中的每个元素,这n个整数的范围是[1,1000000000]。
输出:
对应每个测试案例,输出出现的次数超过数组长度的一半的数,如果没有输出-1。
样例输入:
9
1 2 3 2 2 2 5 4 2
样例输出:
2
最直观的解法:
将数组进行排序,选取中位数,然后依次比较是否值与中位数相等,总数大于n/2即可。
#include <iostream>
#include<stdio.h>
using namespace std;
//找基准位置
int adjust(int a[],int left,int right){
int x = a[left];
while(left<right){
while(left<right&&a[right]>x){
right--;
}
if(left<right){
a[left] = a[right];
left++;
}
while(left<right&&a[left]<x){
left++;
}
if(left<right){
a[right] = a[left];
right--;
}
}
a[left] = x;
return left;
}
//递归(使基准位置区间为一个数为止)
void quick_sort(int a[],int left,int right){
if(left<right){
int i = adjust(a,left,right);
quick_sort(a,left,i-1);
quick_sort(a,i+1,right);
}
}
int middle(int *a,int length){
int x = a[length/2];
int count = 0;
for(int i=0;i<length;i++){
if(x==a[i]){
count++;
}
}
if(count*2>length){
return x;
}
return -1;
}
int main(){
int n;
while(scanf("%d",&n)!=EOF){
int* a = new int[n];
for(int i=0;i<n;i++){
scanf("%d",&a[i]);
}
quick_sort(a,0,n-1);
printf("%d\n",middle(a,n));
}
return 0;
}
O(n)解法:
#include <iostream>
#include<stdio.h>
using namespace std;
int search(int* numbers,int length){
int times = 0,result;
for(int i=0;i<length;i++){
if(times==0){
result = numbers[i];
times=1;
}else{
if(result==numbers[i]){
times++;
}else{
times--;
}
}
}
times = 0;
//检查次数是否过半
for(int i=0;i<length;i++){
if(numbers[i]==result){
times++;
}
}
if(times*2>length){
return result;
}
return -1;
}
int main(){
int n;
while(scanf("%d",&n)!=EOF){
int* a = new int[n];
for(int i=0;i<n;i++){
scanf("%d",&a[i]);
}
printf("%d\n",search(a,n));
}
return 0;
}