LittleLawson的博客

不积跬步,无以至千里。

SparkSession中出现Exception in thread "main" java.lang.AbstractMethodError

1.使用SparkSession时,出现异常:Exception in thread "main" java.lang.AbstractMethodError
2.查看pom.xml文件,是否是因为spark-core和spark-sql的版本不匹配导致?

<dependency>
        <groupId>org.apache.spark</groupId>
        <artifactId>spark-core_2.11</artifactId>
        <version>2.3.0</version>
    </dependency>
    <!-- https://mvnrepository.com/artifact/org.apache.spark/spark-sql -->
    <dependency>
        <groupId>org.apache.spark</groupId>
        <artifactId>spark-sql_2.11</artifactId>
        <version>2.3.0</version>
    </dependency>
阅读更多

扫码向博主提问

去开通我的Chat快问

liu16659

做一名真诚正直优秀的科技人员。
  • 擅长领域:
  • Kafka
  • Scala
  • Spark
  • Hadoop
  • Java
版权声明:注明原文链接,欢迎转载。 https://blog.csdn.net/liu16659/article/details/79981493
个人分类: Spark
上一篇Spark学习笔记之二
下一篇Centos 6.5下安装Mysql
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭