POJ 3187 Backward Digit Sums【杨辉三角】【全排列】

Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5681 Accepted: 3292

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.


STL~~

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[20];

int fun(int n, int m)
{
	int ans = 1;
	for(int i = 0; i < m; ++i)
	{
		ans = ans*(n-i)/(i+1);
	}
	return ans;
}
int main()
{
	int n, sum;
	scanf("%d%d", &n,&sum);
	int i;
	for(i = 0; i < n; i++)  a[i] = i+1;
	while(1)
	{
		int ans = 0;
		for(i = 0; i < n; ++i)
		{
			ans += fun(n-1, i) * a[i];
		}
		if(sum == ans)   break;
		next_permutation(a, a+n);
	}
	for(i = 0; i < n; ++i)
		printf(i!=n-1?"%d ":"%d\n", a[i]);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值