nyoj 1277 && 河南省第九届ACM竞赛F题

Decimal integer conversion

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
XiaoMing likes mathematics, and he is just learning how to convert numbers between differentbases , but he keeps making errors since he is only 6 years old. Whenever XiaoMing converts anumber to a new base and writes down the result, he always writes one of the digits wrong.For example , if he converts the number 14 into binary (i.e., base 2), the correct result should be"1110", but he might instead write down "0110" or "1111". XiaoMing never accidentally adds ordeletes digits, so he might write down a number with a leading digit of " 0" if this is the digit shegets wrong.Given XiaoMing 's output when converting a number N into base 2 and base 3, please determinethe correct original value of N (in base 10). (N<=10^10)You can assume N is at most 1 billion, and that there is a unique solution for N. 
输入
The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8)
Each test case specifies:
* Line 1: The base-2 representation of N , with one digit written incorrectly.
* Line 2: The base-3 representation of N , with one digit written incorrectly.
输出
For each test case generate a single line containing a single integer , the correct value of N
样例输入
1
1010
212
样例输出
14

题意:给定两个字符串,第一个是一个二进制数,第二个是三进制,两个进制表示的数的结果是一样的,但是,现在两者都有且只有一位错误了,问:通过分别改正错的那一位,计算出两者的正确值


首先,我先唠叨几句....英文题伤脑筋发火发火发火,这个题并不难,不过。。可惜了啊,唉 说多了尽是泪大哭大哭大哭,当时好不容易翻译出来了,但是测试的时候居然输出了好几个答案,当时第一反应就是题我们写错了,因为时间不太够了,我们也没再耗费时间在这个题上,可是。。可是。。  答案时间上就是有好多种,不过后台给的测试数据可能就只有一个答案,so~~~~ 再见再见


解题思路:直接套用两层循环,对每一位都进行一次错误的尝试,然后计算结果存起来,最后得到一个二进制的 错误数组,和一个三进制的错误数据,然后寻找其中相同的值就行了

具体代码:
#include <stdio.h>
#include <string.h>
#include <math.h>
int a[50];//二进制错误数组 
int b[105];//二进制错误数组
char s1[50];//二进制字符串 
char s2[50];//三进制字符串 
int main()
{
	int T,i,j,k;
	scanf("%d",&T);
	getchar();
	while(T--)
	{
		gets(s1);
		gets(s2);
		int len1=strlen(s1);
		int len2=strlen(s2);
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=0;i<len1;i++)
		{
			s1[i]=(s1[i]-'0'+1)%2+'0';//对进制取错位 
			for(j=0;j<len1;j++)
				a[i]+=(s1[j]-'0')*(int)pow(2,len1-1-j);
			s1[i]=(s1[i]-'0'+1)%2+'0';//还原进制字符串,确保每次只有一位错误 
		}
		for(i=0,k=0;i<len2;i++)
		{
			s2[i]=(s2[i]-'0'+1)%3+'0';//原理同二进制中的代码 
			for(j=0;j<len2;j++)
				b[k]+=(s2[j]-'0')*(int)pow(3,len2-1-j);
			k++;
			s2[i]=(s2[i]-'0'+1)%3+'0';//每次累加 1 取错位 
			for(j=0;j<len2;j++)
				b[k]+=(s2[j]-'0')*(int)pow(3,len2-1-j);
			k++;
			s2[i]=(s2[i]-'0'+1)%3+'0';//还原 
		}
		for(i=0;i<len1;i++)
			for(j=0;j<k;j++)
				if(a[i]==b[j])
				{
					printf("%d\n",a[i]);
					break;
				}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值