Anniversary party

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests’ ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5

#树形动态规划问题

我们需要利用
dp[i][1]= sum( dp[j][0] )
dp[i][0]= sum( max (dp[j][1], dp[j][0])) //j为i的儿子节点
套用公式就可以了。

##题意

公司开party直系老板不能和员工同是出席,太拘束,会不开心,每个人都会有一个开心值,求最大的开心值。
–这就是根与树的关系。
dp[fa][0]+=dp[son][1];
dp[fa][1]+=max(dp[son][0],dp[son][1]); //其中son为儿子节点,fa为爸爸节点。解释一下,0代表老板出席,1代表老板不出席。那么dp[fa][1]代表老板不出席时他的开心值就为儿子节点是否出席的最大值,dp[fa][0]代表老板出席时开心值就要加上孙子节点的开心值。说起来有点绕,代码如下:

#include<iostream>
#include<cmath>
#include<cstring>
#include<vector>
#include<cstdio>
using namespace std;
const int maxn=10100;
vector<int>ve[maxn];//记录员工与老板关系
int dp[maxn][2];//记录i为0表示被邀请,i为1表示没被邀请
int wa[maxn];//记录节点作为儿子节点出现的次数
int ha[maxn];//记录快乐值
int flag[maxn];//记录节点是否出现过,出现过为1,未出现则为0;
void dfs(int ba){
    dp[ba][0]=ha[ba];
    dp[ba][1]=0;
    flag[ba]=1;
    for(int i=0;i<ve[ba].size();i++){
        int son=ve[ba][i];
        if(flag[son]==1){
            continue;
        }
        dfs(son);
        dp[ba][0]+=dp[son][1];
        dp[ba][1]+=max(dp[son][0],dp[son][1]);//理解这两个公式
    }
}
int main(){
    int num;
    while(scanf("%d",&num)!=EOF){
        int bo,em;
        memset(dp,0,sizeof(dp));
        memset(wa,0,sizeof(wa));
        memset(ha,0,sizeof(ha));
        memset(flag,0,sizeof(flag));
        for(int i=1;i<=num;i++){
            scanf("%d",&ha[i]);
        }
        for(int i=1;i<=num;i++){
            ve[i].clear();
        }
        while(1){
            scanf("%d%d",&em,&bo);
            if(em==0&&bo==0){
                break;
            }
            ve[bo].push_back(em);
            wa[em]++;
        }
        int gen;
        for(int i=1;i<=num;i++){
            if(wa[i]==0){
                gen=i;
                break;
            }
        }
        dfs(gen);
        printf("%d\n",max(dp[gen][0],dp[gen][1]));
    }
    return 0;
}

复习时注意理解。早日脱白。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺旺的碎冰冰~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值