3523 Fence Repair

Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 32347 Accepted: 10391

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).



这个题的题意比较复杂,说的应该是:

有个人需要截木板,现在知道已经截成的每一段的长度(加起来就是总长度),还有总共截过的总次数,每次截木板都需要支付和当前操作的木板长度相同的钱,求这个人想完成这个目标,最少花多少钱,

分析:

已经给出的是当前截的长度,这个题题意不太好理解,这个要求最省钱,那么咱们逆着推导....


也许情景不好想,那么咱们模拟把他连接回来,为了最省钱,每次都优先考虑最小的(好像有一个定理),这样才最终保证花的钱最少,具体原因想想看,贪心!

用优先队列比较方便,这个题和 南阳oj 57 一样,只是换了一种方式来做,而且别忘对n==1的情况,其实不特判这个,也是可以ac的.....(这个我就不懂了......)



#include<stdio.h>
#include<queue>
using namespace std;
int main()
{
	int n,i,a;long long sum;
	while(~scanf("%d",&n))
	{
		priority_queue<int,vector<int>,greater<int> >q;
		for(i=0;i<n;++i)
		{
			scanf("%d",&a);
			q.push(a);//全部入队列
		}
		sum=0;
		if(n==0)
		{
			sum=q.top();//特判这个
		}
		while(q.size()>1)
		{
			a=q.top();q.pop();//弹出两个最小的相加
			a+=q.top();
			sum+=a;//这个是花的钱数
			q.push(a);//粘好后放在一边,继续找两个最小的开始粘...
			q.pop();
		
		}
		printf("%lld\n",sum);//注意类型...
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值