Poj 2385 Apple Catching【dp】

Apple Catching
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10192 Accepted: 4939

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

Source


题意:

有两颗苹果树,每分钟(一共t分钟)都有一棵树上掉下一个苹果,某只奶牛最多移动w 步,问这只奶牛最多能吃到多少苹果


题解:

dp 最重要的是找到递推式

现在 i 代表时间,或者说苹果的编号,j 表示第多少步移动

1,首先不考虑某时候是否接到苹果,某时刻可能在前一时刻就在这个位置,或者上一步刚移动过来,也就是dp[i][j]=max(dp[i-1][j],dp[i-1][j-1])

2,考虑这个时刻是否有接到苹果,累加到当前状态

3,查找步数全部走完可以得到的最大值,输出


/*
http://blog.csdn.net/liuke19950717
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int x[1005],dp[1005][35];
int ok(int j,int k)// j 是走动步数,k 掉苹果的树号
{
    if(j&1)//走动奇数步时到了第二号树下
    {
        return k==2;
    }
    return k==1;
}
int slove(int n,int m)
{
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=n;++i)//时间
    {
        dp[i][0]=dp[i-1][0]+ok(0,x[i]);//某时刻不动的情况
        for(int j=1;j<=m&&j<=i;++j)//尝试走动
        {
            int tp=ok(j,x[i]);//判断是否接到苹果
            dp[i][j]=tp+max(dp[i-1][j],dp[i-1][j-1]);
            //上一分钟就在这里,或者上一分钟时移动到这里
        }
    }
    int cnt=0;
    for(int i=1;i<=m;++i)
    {
        cnt=max(dp[n][i],cnt);
    }
    return cnt;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&x[i]);
        }
        printf("%d\n",slove(n,m));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值