poj 3009 ( Curling 2.0 深搜 搜直线)

题目链接:http://poj.org/problem?id=3009

                                                                                                                                 Curling 2.0

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11679 Accepted: 4945

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

Source

先说一下题意:(1) 一个球有四个方向可以走,上下左右;题目中提到这个球的运动方向受到了限制,只能走直线,沿着一个方向一直走下去,并且在这个方向上停止的条件是当前位置的下一个位置是障碍物,那么球会在当前位置停下,并且当前位置的下一位置的障碍物消失,那么这种情况算滚动1次;

                            (2)如果滚动次数超过10次,那么就输出-1,正因为这样,可以暴力穷举;

                              (3)   另外一种情况:如果球滚出界了,那么游戏结束;

思路:        这道题一看感觉无从下手,和其他题不一样,搜索不是一步一步的,而是整条直线的搜(其实是把直线分解成若干步);

                   

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <string>
    #include <cstdio>
    #include <cmath>
    #define  judge(x,y) x>=1&&x<=n&&y>=1&&y<=m&&map[x][y]!=1

    using namespace std;

    int n,m,sx,sy,ex,ey; //设置全局变量
    int map[25][25];

    //设置方向数组优化深搜代码
    int xx[]={-1,1,0,0};
    int yy[]={0,0,-1,1};
    int step,steps;

    void dfs(int x,int y)
    {

      if(step>10)return;     //  递归出口,步数大于10步就返回

      for(int i=0;i<4;i++)
      {
        int dx=x+xx[i];
        int dy=y+yy[i];
        int ok=0;  //作为某个方向能不能走的一个标志变量

        while(judge(dx,dy))
        {
            ok=1;
            if(dx==ex&&dy==ey)
            {
              if(step<steps)steps=step;
            }
            dx+=xx[i]; //搜索整条直线
            dy+=yy[i];
        }
        if(map[dx][dy]==1&&ok)
        {
            step++;
            map[dx][dy]=0;
            dfs(dx-xx[i],dy-yy[i]);
            step--;
            map[dx][dy]=1;
        }
      }

    }

    int main()
    {
            while(cin>>m>>n)
            {
                if(n==0&&m==0)break;
                memset(map,0,sizeof(map));
                for(int i=1;i<=n;i++)
                 for(int j=1;j<=m;j++)
                  {
                      cin>>map[i][j];
                      if(map[i][j]==2){sx=i;sy=j;}
                      if(map[i][j]==3){ex=i;ey=j;}
                  }
                step=1;
                steps=1000000;
                dfs(sx,sy);

                if(steps>10) cout<<-1<<endl;
                else  cout<<steps<<endl;
            }
            return 0;
    }

  • 3
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值