PAT——Student List for Course(注意运行超时问题)

Student List for Course

题目

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
结尾无空行

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
结尾无空行

AC代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
	map<int,vector<string> > maps;
	int n,k;
	cin>>n>>k;	
	for(int i=0;i<n;i++)
	{
		string s;
		cin>>s;
		int num;
		cin>>num;
		while(num--)
		{
			int t;
//			cin>>t;
			scanf("%d",&t);
			maps[t].push_back(s);
		}
	}
	for(int i=1;i<=k;i++)
	{
		cout<<i<<" "<<maps[i].size()<<endl;
		sort(maps[i].begin(),maps[i].end());
		for(int j=0;j<maps[i].size();j++)
//		cout<<maps[i][j]<<endl;
		printf("%s\n",maps[i][j].c_str());
	}
}

注意

如果最后一个测试点运行超时,可以试试将cin,cout改为scanf和printf

在此之上又有一个问题就是如何输出string类型的数据,需要进行如下处理,(具体可见这篇文章——printf输出string类型

printf("%s\n",maps[i][j].c_str());
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值