中标麒麟6.0 QT开发环境安装和搭建

最近用到中标麒麟6.0,需要用QT开发,QT又依赖于C++。。。坑爹的事就来了

中标麒麟默认不装gcc-c++,自带的yum源服务器不开。网上试了各种方案,基本上都失效了。 无奈之下只好另辟蹊径,在网上搜到有人说打中标麒麟的客服,客服说让用fedora 18的yum源,google之,添加之。妈蛋,说依赖包已经被安装,但是版本不一致,看了下出错原因,中标麒麟把包名后缀改成.nl了,水平太低不会改依赖。

后来又下了fedora 17,看了下系统里面包,居然和中标麒麟一样,最终试了试在fedora 17下开发QT程序,然后放到中标麒麟下运行,完美解决。

fedora 17安装QT的时候可以修改下yum源到光盘。fedora 17ISO最好下完全版的接近4G包任你装

阅读更多
想对作者说点什么? 我来说一句

使用yum安装g++

2013年07月03日 3KB 下载

没有更多推荐了,返回首页

不良信息举报

中标麒麟6.0 QT开发环境安装和搭建

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭