1001. A+B Format (20)

1001. A+B Format (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991


分析:
  这个题目的运算很简单,就是计算a+b的值res,(其中flag为res的符号)重点在计算之后如何格式化输出。 这里有几点需要讨论,
1. 当res == 0 时候,直接输出
2. 当res != 0时候, 若res < 0 , 令flag = -1; 若res > 0, 则flag = 1,然后对res的绝对值按位压入栈,并且每三位 数字则让一个逗号入栈, 最后,如果flag = -1, 则先输出‘-’,flag = 1,则不做处理,然后将此栈输出即可

 
#include<iostream>
#include<stack>
#include<string.h>
#include<string>
using namespace std;

int main()
{
    int a, b;
    cin>>a>>b;
    int answer = a + b;

    stack <char> stack1;
    while (!stack1.empty()) {
        stack1.pop();
    }
    if (answer < 0) {
        cout<<'-';
        answer = -1 * answer;
    } else if (answer == 0) {
        cout<<0<<endl;
        return 0;
    }

    int num = 0;
    while (answer != 0) {
        char temp = answer % 10 + '0';
        stack1.push(temp);
        num += 1;
        if (num%3 == 0) {
            stack1.push(',');
        }
        answer = answer / 10;
    }
    char ch = stack1.top();
    if (ch == ',') {
        stack1.pop();
    }
    while (!stack1.empty()) {
        ch = stack1.top();
        cout<<ch;
        stack1.pop();
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值