POJ 2240 Arbitrage(Ballman最短路)

Arbitrage
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

这道题和POJ1860十分相似,可以说在ACM里面算是完全一样的题目了,你只需要用个map处理一下这些货币的名字,转化为数字,再用Bellman算法就能得到答案,也没什么坑点,但是一开始我1860是用非主流的方法过的,导致这道题用1860的方法一直wa,学习了一下别人的做法才明白自己错在哪里了。

代码如下:

#include<cstdio>
#include<cstring>
#include<map>
#include<string>
using namespace std;
#define N 1005
#define eps 1e-7
int key, n, m;

typedef struct Edge //边
{
	int u, v;
	double rate;
}Edge;

Edge edge[N];
double dis[N];

bool Bellman_Ford()
{
	for(int i = 1; i <= n; ++i) 
		dis[i] = (i == 1 ? 1.0 : 0.0);
	for(int i = 1; i <= n - 1; ++i)
		for(int j = 1; j <= m; ++j)
			if(dis[edge[j].u] * edge[j].rate > dis[edge[j].v]) 
			{
				dis[edge[j].v] = dis[edge[j].u] * edge[j].rate;
			}
	for(int i = 1; i <= m; ++i)//判断是否存在不断增加的环
		if(dis[edge[i].v] < dis[edge[i].u] * edge[i].rate)
		{
			return true;
		}
	return false;
}

int main()
{
	int k = 1, i, j;
	double t;
	char s1[100],s2[100];
	map<string,int>atlas;
	while(1)
	{
		scanf("%d",&n);
		if(n == 0)
			break;
		for(i = 1; i <= n; i++)
		{
			scanf("%s",s1);
			atlas[s1] = i;
		}
		scanf("%d",&m);
		for(i = 1; i <= m; i++)
		{
			scanf("%s%lf%s",s1,&t,s2);
			edge[i].u=atlas[s1];
			edge[i].v=atlas[s2];
			edge[i].rate=t;
		}
		if(Bellman_Ford())
			printf("Case %d: Yes\n",k++);
		else
			printf("Case %d: No\n",k++);
		atlas.clear();
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值