T - 20

Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 

Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0
题意:

从一个点到另一个点的步数

分析:
其实就是简单的八皇后,但是他给出的点也有可能到达不了,所以一定要在返回值的最后写return 0

代码:

#include<iostream>
#include<stdio.h>
#include<queue>
#include<algorithm>
#include<math.h>
#include<cstring>
using namespace std;
struct num
{
    int x,y;
    long long int second;
};
int a[8][2]={-2,-1,-2,1,-1,-2,-1,2,1,2,1,-2,2,-1,2,1};
int b[305][305],n,m,N;
long long int bfs(int q,int w)
{
    queue<num>v;
    int i;
    num d,l;
    d.x=q;
    d.y=w;
    d.second=0;
    b[q][w]=1;
    v.push(d);
    while(!v.empty())
    {
        d=v.front();
        v.pop();
        if(d.x==n&&d.y==m)
            return d.second;
        for(i=0;i<8;i++)
        {
            q=d.x+a[i][0];
            w=d.y+a[i][1];
            if(!b[q][w]&&q>=0&&q<N&&w>=0&&w<N)
            {
                l.x=q;
                l.y=w;
                b[q][w]=1;
                l.second=d.second+1;
                //cout<<"qqq"<<q<<endl;
                //cout<<"wwww"<<w<<endl;
                v.push(l);
            }
        }
    }return 0;
}
int main()
{
    int i,j,f,tt=0,L,R,t;
    cin>>t;
    for(i=0;i<t;i++){
    cin>>N;
    cin>>L>>R>>n>>m;
        memset(b,0,sizeof(b));
        cout<<bfs(L,R)<<endl;
    }
}

感受:

把到达不了的情况忘了,老是wrong难过

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值