PAT甲级1001

PAT甲级1001 1001 A+B Format (20分)

题目

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106​​ ≤a,b≤106. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991

我写的

#include<stdio.h>
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        int sum=a+b;
        int real_sum[8];
        int size=0;
        if(sum==0)//注意sum=0的情况
        {
            printf("%d",sum);
            return 0;
        }
        else if(sum<0)//负数的余数会一直是负数
        {
            printf("-");
            sum=-sum;
        }
        while(sum!=0)
        {
            size++;
            real_sum[size]=sum%10;//用real_size存储sum
            sum=sum/10;
        }
        
        for(int i=size;i>0;i--)
        {
            printf("%d",real_sum[i]);
            if((i-1)%3==0&&i!=1)printf(",");//commas[i-1]==1和(i-1)%3==0居然结果不一样...可能因为少了i!=1吧
            else {;}

        }
    }
    return 0;
}

注意事项

都是一些边界情况没有考虑,导致一直检测出错

改进

可以使用sprintf函数,将sum直接放进字符串中

sprintf(real_sum, "%d", sum)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值