HDU A + B Again

A + B Again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11804 Accepted Submission(s): 5152


Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
  
  
+A -A +1A 12 1A -9 -1A -12 1A -AA

Sample Output
  
  
0 2C 11 -2C -90


总结:   Long.parseLong(s,16);将16进制的字符串转化为十进制

           Long.toString(sum,16)将一个十进制数字转换为一个个十六进制的字符串

           toUpperCase();  将字符串中的小写字母转换为大写字母

 

import java.util.*;
import java.io.*;
import java.math.BigInteger;
public class Main {

	public static void main(String[] args) {
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		while(sc.hasNext()){
		String  s1=sc.next();
		String s2=sc.next();
		long num1=fun(s1);
		long num2=fun(s2);
		long sum=num1+num2;
		String str=Long.toString(sum,16).toUpperCase();//将一个十进制数字转换为一个个十六进制的字符串,将字符串中的小写字母转换为大写字母
		System.out.println(str);
		}
	}
	public static long fun(String s){
		if(s.charAt(0)=='+')
			s=s.substring(1);
		return Long.parseLong(s,16);//将16进制的字符串转化为十进制
	}
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值