POJ - 1971 - Parallelogram Counting

Parallelogram Counting
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 6466 Accepted: 2248

Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case.
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.

Output

Output should contain t lines.
Line i contains an integer showing the number of the parallelograms as described above for test case i.

Sample Input

2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8

Sample Output

5
6



 当两条线段中点重合时,四个顶点组成一个平行四边形

#include<iostream>
#include<algorithm>
using namespace std;
struct AP
{
    int x,y;
} a[1008];
struct AD
{
    double x,y;
} com[510000];
bool compare(AD a,AD b);
int main()
{
    int N;
    cin>>N;
    while(N--)
    {
        int n,x=0;
        cin>>n;
        for(int i=0; i<n; i++)
            cin>>a[i].x>>a[i].y;
        for(int i=0; i<n-1; i++)
            for(int j=i+1; j<n; j++)
            {
                com[x].x=(a[i].x+a[j].x)/2.0;
                com[x].y=(a[i].y+a[j].y)/2.0;
                x++;
            }
        sort(com,com+x,compare);
        double comx=com[0].x,comy=com[0].y;
        int ans=0,add=1;
        for(int i=1; i<x; i++)
             if(comx==com[i].x&&comy==com[i].y)
                add++;
            else
            {
                comx=com[i].x;
                comy=com[i].y;
                ans+=(add-1)*add/2;
                add=1;
            }
        ans+=(add-1)*add/2;
        cout<<ans<<endl;
    }
    return 0;
}
bool compare(AD a,AD b)
{
    if(a.x!=b.x)
        return a.x<b.x;
    else
        return a.y<b.y;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值