1044 Shopping in Mars (25分)【元素查找】

1044 Shopping in Mars (25分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题目大意:

给出一个数字序列与一个数S,在数字序列中求出所有和为S的子序列(区间下标左端点小的优先输出,左端点相同时右端点小的先输出)。若没有这样的序列,求出和值恰好大于S的子序列(即在所有和值大于S的子序列中和值最接近S)。假设下标从1开始。

解题思路:

首先可以利用一个sum数组保存前缀和,而要求A[i]~A[j]的值只要用sum[i]-sum[j]即可。

此外我们可知sum数组是严格单调递增的,那么我们就可以使用二分法来求解。

假设需要在序列A[1]~A[n]中寻找和值为S的连续子序列,就可以枚举左端点i,然后在sum数组d[i,n]范围内查找值为sum[i]+S的元素是否存在:如果存在则把对应的下标作为右端点j;如果不存在,找到第一个使和值超过S的右端点j。

注意:使用lower_bound()函数会方便不少。 

#include<iostream>
#include<algorithm>
using namespace std;

int sum[100010] = { 0 };
int n, s,mins = 1e9;

int main()
{
	cin >> n >> s;
	for (int i = 1; i <= n; i++)
	{
		cin >> sum[i];
		sum[i] += sum[i - 1];
	}
	for (int i = 1; i <= n; i++)
	{
		int j = lower_bound(sum + 1, sum + 1 + n, sum[i - 1] + s) - sum;
		if (sum[j] - sum[i - 1] == s)
		{
			mins = s;
			break;
		}
		else if (j <= n&&sum[j] - sum[i - 1] < mins)
		{
			mins = sum[j] - sum[i - 1];
		}
	}
	for (int i = 1; i <= n; i++)
	{
		int j = lower_bound(sum + 1, sum + 1 + n, sum[i-1] + mins) - sum;
		if (sum[j] - sum[i - 1] == mins)
		{
			cout << i << "-" << j << endl;
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值