1078 Hashing (25分)【hash、素数】

1078 Hashing (25分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

题目大意:

给出散列表的长度TSize和欲插入的元素,将这些元素按读入的顺序插入散列表中,其中散列函数为H(key)=key%TSize,冲突解决采用二次探查法,另外,如果题目中给出的TSize不是素数,那么需要将TSize重新赋值为第一个比TSize大的素数再进行插入。 

让我们来理解一下样例:

TSize为4,所以需要先找到比4大的第一个素数(即5),于是TSize=5。接着插入四个元素:

  • key=10,H(10)=10%5=0,因此将10插入0号位;
  • key=6,H(6)=6%5=1,因此将6插入1号位;
  • key=4,H(4)=4%5=4,因此将4插入4号位;
  • key=15,H(15)=15%5=0,发生冲突;采用二次探查法,H(15+1*1)=1,发生冲突;H(15+2*2)=4,发生冲突;H(15+3*3)=4,发生冲突;H(15+4*4)=1,发生冲突......可以证明后面找不到一个不冲突的点。

解题思路:

  1. 首先,对于一个输入的TSize,如果不是素数,则必须找到其第一个比它大的素数。
  2. 用一个数组hashTable[]来存储key号位的使用情况,hashTable[m] = 0,表示m号位未使用。
  3. 对于每一个插入的元素a,计算H(a)并判断对应位置是否被使用。如果未被使用,那么就找到可以插入的位置,并输出。如果已经被使用,根据二次探查法,令步长step初值为1,然后令下一个检测值为(a+step*step)%TSize,判断该位置是否已被占用,如果已被占用则令step++,再进行判断。当step增加到TSize时如果还不存在可用的位置,则表明这个元素无法被插入。
#include<iostream>
#include<cstdio>
#include<math.h>
#include<vector>
using namespace std;
#define maxn 10010

int hashTable[maxn] = { 0 };

int isPrime(int n)    //判断n是否为负数
{
	if (n <= 1)
		return 0;
	for (int i = 2; i <= sqrt(n); i++)
	{
		if (n%i == 0)
			return 0;
	}
	return 1;
}

int main()
{
	int n, TSize, a;
	cin >> TSize >> n;
	while (!isPrime(TSize))
		TSize++;
	for (int i = 0; i < n; i++)
	{
		cin >> a;
		int pos = a%TSize;
		if (hashTable[pos] == 0)
		{
			hashTable[pos] = 1;
			if (i == 0)
				cout << pos;
			else cout << " " << pos;
		}
		else
		{
			int step;   //步长
			for (step = 1; step < TSize; step++)
			{
				pos = (a + step*step) % TSize;
				if (hashTable[pos] == 0)
				{
					hashTable[pos] = 1;
					if (i == 0)
						cout << pos;
					else cout << " " << pos;
					break;
				}	
			}
			if (step >= TSize)
			{
				if (i > 0)
					cout << " ";
				cout << "-";
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值