POJ3687 Labeling Balls【优先队列+反向拓扑排序】

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

解题思路

题目大意:这道题目的意思比较难理解,在基本的拓扑排序的基础上又增加了一个要求:编号最小的节点要尽量排在前面;在满足上一个条件的基础上,编号第二小的节点要尽量排在前面;在满足前两个条件的基础上,编号第三小的节点要尽量排在前面……依此类推。(注意,这和字典序是两回事,不可以混淆。)参考博文:博文

思路:如上面参考博文提到的一样,我们这里得采用反向拓扑排序,然后使用优先队列,保证编号大的点先出队列。(这里的反向拓扑排序指的是,我们先挑出出度为0的点)。这里要注意,输入的边可能会有重边,即一条边出现两次,此时不能再去增加一遍出度。

代码

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
#define MAXN 210

int t, n, m;
int map[MAXN][MAXN], outdegree[MAXN], ans[MAXN];

int topoSort()
{
	priority_queue<int> q;
	int num = n;
	for (int i = 1; i <= n; i++)
	{
		if (outdegree[i] == 0)
			q.push(i);
	}
	while (!q.empty())
	{
		int u = q.top();
		ans[num--] = u;
		q.pop();
		for (int j = 1; j <= n; j++)
		{
			if (map[j][u])
			{
				outdegree[j]--;
				if (outdegree[j] == 0)
					q.push(j);
			}
		}
	}
	if (num != 0)
		return 0;
	else return 1;
}

int main()
{
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d%d", &n, &m);
		memset(map, 0, sizeof(map));
		memset(outdegree, 0, sizeof(outdegree));
		memset(ans, 0, sizeof(ans));
		for (int i = 1; i <= m; i++)
		{
			int a, b;
			scanf("%d%d", &a, &b);
			if (!map[a][b])
			{
				map[a][b] = 1;
				outdegree[a]++;
			}
		}
		if (!topoSort())
		{
			printf("-1\n");
		}
		else
		{
			int tmp[MAXN];
			for (int i = 1; i <= n; i++)
				tmp[ans[i]] = i;
			for (int i = 1; i <= n; i++)
			{
				if (i != n)
					printf("%d ", tmp[i]);
				else printf("%d\n", tmp[i]);
			}
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值