POJ 3294 Life Forms

Description

You may have wondered why most extraterrestrial life formsresemble humans, differing by superficial traits such as height, colour,wrinkles, ears, eyebrows and the like. A few bear no human resemblance; thesetypically have geometric or amorphous shapes like cubes, oil slicks or cloudsof dust.

The answer is given in the 146th episode of Star Trek - The Next Generation,titled The Chase. It turnsout that in the vast majority of the quadrant's life forms ended up with alarge fragment of common DNA.

Given the DNA sequences of several life forms represented asstrings of letters, you are to find the longest substring that is shared bymore than half of them.

Input

Standard input contains several test cases. Each test case beginswith 1 ≤ n ≤ 100, the number of life forms. n lines follow; each contains a stringof lower case letters representing the DNA sequence of a life form. Each DNAsequence contains at least one and not more than 1000 letters. A linecontaining 0 follows the last test case.

Output

For each test case, output the longest string or strings shared bymore than half of the life forms. If there are many, output all of them inalphabetical order. If there is no solution with at least one letter, output"?". Leave an empty line between test cases.

Sample Input

3
abcdefg
bcdefgh
cdefghi
3
xxx
yyy
zzz
0

Sample Output

bcdefg
cdefgh
 
?

题目大意:给定n个字符串,求出一些最长的子字符串,满足在超过半数的字符串中出现过。

方法:首先,就所有字符串拼接起来。用不同的符号就其分开。同时,我们要记录下每个字符在以前的那个字符串中,避免一个字符串中出现多次的子串被重复计算。接着,通过二分,得到最长的子字符串的长度。接着,遍历满足这一长度并在超过半数的字符串中出现过的子字符串

 

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define MAX 101000
using namespace std;

int n ,num[MAX] ,min1 ,cnt ,location[MAX];
int vis[110];

int wa[MAX] ,wb[MAX] ,wv[MAX] ,ws1[MAX] ,sa[MAX] ,rank1[MAX],height[MAX];

int cmp(int *r,int a,int b,int l)
{
	return r[a]==r[b]&&r[a+l]==r[b+l];
}

void da(int *r,int n,int m)
{
	int i,j,p,*x=wa,*y=wb,*t;
	for(i=0;i<m;i++) ws1[i]=0;
	for(i=0;i<n;i++) ws1[x[i]=r[i]]++;
	for(i=1;i<m;i++) ws1[i]+=ws1[i-1];
	for(i=n-1;i>=0;i--) sa[--ws1[x[i]]]=i;
	for(j=1,p=1;p<n;j*=2,m=p)
	{
		for(p=0,i=n-j;i<n;i++) y[p++]=i;
		for(i=0;i<n;i++) if(sa[i]>=j) y[p++]=sa[i]-j;
		for(i=0;i<n;i++) wv[i]=x[y[i]];
		for(i=0;i<m;i++) ws1[i]=0;
		for(i=0;i<n;i++) ws1[wv[i]]++;
		for(i=1;i<m;i++) ws1[i]+=ws1[i-1];
		for(i=n-1;i>=0;i--) sa[--ws1[wv[i]]]=y[i];
		for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
			x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
	}
	return;
}

void calheight(int *r,int n)
{
	int i,j,k=0;
	for(i=1;i<=n;i++)
		rank1[sa[i]]=i;
	for(i=0;i<n;height[rank1[i++]]=k)
		for(k?k--:0,j=sa[rank1[i]-1];r[i+k]==r[j+k];k++);
	return;
}

bool jian(int x)
{
    int Count = 0;
    char aa[1010];
    memset(vis,false,sizeof(vis));
    for(int i = 2;i <= cnt;i++)
    {
        if(height[i] < x)
        {
            Count = 0;
            memset(vis,false,sizeof(vis));
            continue;
        }
        if(!vis[location[sa[i-1]]])
        {
            vis[location[sa[i-1]]] = true;
            Count++;
        }
        if(!vis[location[sa[i]]])
        {
            vis[location[sa[i]]] = true;
            Count++;
        }
        if(Count > n / 2)
        {
            return 1;
        }
    }
    return 0;
}

void jian1(int x)
{
    int Count = 0;
    char aa[1010];
    memset(vis,false,sizeof(vis));
    for(int i = 2;i <= cnt;i++)
    {
        if(height[i] < x)
        {
            Count = 0;
            memset(vis,false,sizeof(vis));
            continue;
        }
        if(!vis[location[sa[i-1]]])
        {
            vis[location[sa[i-1]]] = 1;
            Count++;
        }
        if(!vis[location[sa[i]]])
        {
            vis[location[sa[i]]] = 1;
            Count++;
        }
        if(Count > n / 2)
        {
            for(int j = 0;j < x;j++)
            {
                aa[j] = num[sa[i]+j]+'a'-1;
            }
            aa[x] = '\0';
            printf("%s\n",aa);
            for(;i<=cnt;i++)
            {
                if(height[i] < x)
                {
                    Count = 0;
                    memset(vis,false,sizeof(vis));
                    break;
                }
            }
        }
    }
}
int main()
{
    char ch[1010];
    int len ,re;
    while(scanf("%d",&n),n)
    {
        min1 = 99999999;
        cnt = 0;
        re = 27;
        for(int i = 0;i<n;i++)
        {
            scanf("%s",ch);
            len = strlen(ch);
            if(len < min1)
            {
                min1 = len;
            }
            for(int j = 0;j<len;j++)
            {
                num[cnt] = ch[j] - 'a' + 1;
                location[cnt++] = i;
            }
            num[cnt] = location[cnt] = re;
            cnt++;
            re++;
        }
        num[cnt] = 0;
        da(num,cnt+1,re);
        calheight(num,cnt);

        int left = 0 ,right = min1 ,ans = 0;
        while(left<=right)
        {
            int mid = (left + right) / 2;
            if(jian(mid))
            {
                left = mid + 1;
                ans = mid;
            }
            else
            {
                right = mid - 1;
            }
        }
        if(!ans)
        {
            printf("?\n\n");
        }
        else
        {
            jian1(ans);
            printf("\n");
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值