hdu 5945 Fxx and game

Problem Description
Young theoretical computer scientist Fxx designed a game for his students.

In each game, you will get three integers  X,k,t .In each step, you can only do one of the following moves:

1.X=Xi(0<=i<=t) .

2. if  k|X,X=X/k .

Now Fxx wants you to tell him the minimum steps to make  X  become 1.
 

Input
In the first line, there is an integer  T(1T20)  indicating the number of test cases.

As for the following  T  lines, each line contains three integers  X,k,t(0t106,1X,k106)

For each text case,we assure that it's possible to make  X  become 1。
 

Output
For each test case, output the answer.
 

Sample Input
  
  
2 9 2 1 11 3 3
 

Sample Output
  
  
4 3
 

Source

BestCoder Round #89



因为x很小,因此可以考虑f[i]表示1到i的最小次数

f[i]=min(f[i-x])

if i%k==0 f[i]=min(f[i/k])

对于第一个转移我们可以直接用单调队列维护

#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
int f[1500001];
int q[1500001];
int main()
{
    int T;
    scanf("%d",&T);
    while(T>0)
    {
        T--;
        int x,k,t;
        scanf("%d%d%d",&x,&k,&t);
        f[1]=0;
        int l=1,r=1;
        q[1]=1;
        int i;
        for(i=2;i<=x;i++)
        {
            while(l<r&&q[l]<i-t)
                l++;
            f[i]=f[q[l]]+1;
            if(i%k==0)
                f[i]=min(f[i],f[i/k]+1);
            while(l<=r&&f[i]<=f[q[r]])
                r--;
            r++;
            q[r]=i;
        }
        printf("%d\n",f[x]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值