哈理工 oj——Simple Line Editor

Simple Line Editor

Time Limit: 1000 MS

Memory Limit: 65536 K

Total Submit: 573(151 users)

Total Accepted: 183(139 users)

Rating:

Special Judge: No

Description

Early computer used line editor, which allowed text to be created and changed only within one line at a time. However, in line editor programs, typing, editing, and document display do not occur simultaneously (unlike the modern text editor like Microsoft Word). Typically, typing does not enter text directly into the document. Instead, users modify the document text by entering simple commands on a text-only terminal.

 

Here is an example of a simple line editor which can only process English. In addition, it has two commands. ‘@’ and ‘#’. ‘#’ means to cancel the previous letter, and ‘@’ is a command which invalidates all the letters typed before. That is to say, if you want type “aa”, but have mistakenly entered “ab”, then you should enter ‘#a’ or ‘@aa’ to correct it. Note that if there is no letter in the current document, ‘@’ or ‘#’ command will do nothing.

Input

The first line contains an integer T, which is the number of test cases. Each test case is a typing sequence of a line editor, which contains only lower case letters, ‘@’ and ‘#’.

Output

For each test case, print one line which represents the final document of the user. There would be no empty line in the test data.

Sample Input

2
ab#a
ab@aa

Sample Output

aa
aa

 

想着用 两个方法做,用STL做的时候 ,好多容器细节,都搞不懂,把这些细节查懂了后,做起来如鱼得水。

vector容器来做:

#include<iostream>
#include<vector>
#include<string>
using namespace std;
int main()
{
	string str;
	int T;
	cin>>T;
	while(T--)
	{
		cin>>str;
		vector<char>ls;
		for(int i=0;i<str.size();i++)
		{
			if(((str[i]=='#')||(str[i]=='@'))&&(ls.size()==0))
			continue;
			
			else if(str[i]=='@')
				ls.clear();
			else if(str[i]=='#')
				ls.pop_back();

			else 
			{
				ls.push_back(str[i]);
				
			}
		}
		for(vector<char>::iterator iter=ls.begin();iter!=ls.end();iter++)
			cout<<*iter;
		cout<<endl;
		ls.clear();
		
	}
	return 0;
}


 

用刚学的栈来做!

更加顺利!要注意每次pop()之前都要检查 栈是否为空。

AC:

#include<iostream>
#include<stack>
#include<string>
using namespace std;

int main()
{
	int T;cin>>T;
	string str;
	while(T--)
	{
		stack<char>gq;
		cin>>str;
		for(int i=0;i<str.size();i++)
		{
			if(str[i]!='#'&&str[i]!='@')
				gq.push(str[i]);
			else if(str[i]=='#'&&!gq.empty())
				gq.pop();
			else if(str[i]=='@'&&!gq.empty())
			{
				while(!gq.empty())
				{
					gq.pop();
				}
			}
		}
		int dic=0;char cnt[100000];
		while(!gq.empty())
		{
			cnt[dic++]=gq.top();
			gq.pop();
		}
		for(int t=dic-1;t>=0;t--)
			cout<<cnt[t];
		cout<<endl;

	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值