poj1041 John's trip (无向图求欧拉回路方案)

John's trip
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5950 Accepted: 1946 Special Judge

Description

Little Johnny has got a new car. He decided to drive around the town to visit his friends. Johnny wanted to visit all his friends, but there was many of them. In each street he had one friend. He started thinking how to make his trip as short as possible. Very soon he realized that the best way to do it was to travel through each street of town only once. Naturally, he wanted to finish his trip at the same place he started, at his parents' house. 

The streets in Johnny's town were named by integer numbers from 1 to n, n < 1995. The junctions were independently named by integer numbers from 1 to m, m <= 44. No junction connects more than 44 streets. All junctions in the town had different numbers. Each street was connecting exactly two junctions. No two streets in the town had the same number. He immediately started to plan his round trip. If there was more than one such round trip, he would have chosen the one which, when written down as a sequence of street numbers is lexicographically the smallest. But Johnny was not able to find even one such round trip. 

Help Johnny and write a program which finds the desired shortest round trip. If the round trip does not exist the program should write a message. Assume that Johnny lives at the junction ending the street appears first in the input with smaller number. All streets in the town are two way. There exists a way from each street to another street in the town. The streets in the town are very narrow and there is no possibility to turn back the car once he is in the street 

Input

Input file consists of several blocks. Each block describes one town. Each line in the block contains three integers x; y; z, where x > 0 and y > 0 are the numbers of junctions which are connected by the street number z. The end of the block is marked by the line containing x = y = 0. At the end of the input file there is an empty block, x = y = 0.

Output

Output one line of each block contains the sequence of street numbers (single members of the sequence are separated by space) describing Johnny's round trip. If the round trip cannot be found the corresponding output block contains the message "Round trip does not exist."

Sample Input

1 2 1
2 3 2
3 1 6
1 2 5
2 3 3
3 1 4
0 0
1 2 1
2 3 2
1 3 3
2 4 4
0 0
0 0

Sample Output

1 2 3 5 4 6 

此题目从半上午做到这时候,首先把算法弄懂了,然后就是找bug将近三个小时!!bug?判断相等的时候要用两个等号 活生生少写一个!!!!醉了~。核心思想是在判断完有欧拉回路的情况下,这个可以从所有点度数都是偶数的充分条件来判定,然后从标号最小的边开始dfs,因为程序里有个对邻接表排序的过程你,那么必然之后沿着边的标号上升的dfs过程。遇到走不通就回溯,那么此时必然还要存在环,否则不会出现走不通,那时应该全图是一个环才对。遇到最小序环(假设存在)且无法继续dfs回溯的时候,回溯出来的那条边必然到最后是欧拉回路最后一条边,直接push,否则就会出现沿着欧拉回路走的时候“过快”的回到原点了。遇到最小序环且无法走通的情况下,此时就要从最小序环遍历各点dfs并按照边标号上升的顺序深搜其他环,那么path里面到最后就保存的是欧拉路径的 逆序,reverse一下就么么哒了~
<pre name="code" class="cpp">#include<iostream>
 #include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;

//input: adj 全局变量,adj【i】表示从结点i连出的所有边
//判断是否有解。有向无向皆可,path(全局)保存欧拉回路。
const int maxn=2000;
const int maxm=1000000;
int father[maxn];
vector< pair<int,int > > adj[maxn];
bool vis[maxm];

int getFather(int x)
{
     return x==father[x]?x:father[x]=getFather(father[x]);
//    int root=a;
//    int temp;
//    while(father[root]!=root)
//        root=father[root];
//    while(father[a]!=root)
//    {
//        temp=a;
//        a=father[a];
//        father[temp]=root;
//    }
}

void add (int x,int y,int z)
{
    adj[x].push_back(make_pair(z,y));
    adj[y].push_back(make_pair(z,x));
}

vector<int >path;

void dfs(int u)
{
    for(int it=0; it<adj[u].size(); it++)
        if(!vis[adj[u][it].first])
        {
            vis[adj[u][it].first]=1;
            dfs(adj[u][it].second);
            path.push_back(adj[u][it].first);
        }
}

bool solve()
{
    for(int i=0; i<maxn; i++)
        father[i]=i;
    for(int i=0; i<maxn; i++)
    {
        for(int j =0; j < adj[i].size() ; ++j)
        {
            father[getFather(i)]=getFather(adj[i][j].second);
        }
    }
    int origin=-1;
    for(int i=0; i<maxn; i++)
        if(adj[i].size())
        {
            if(adj[i].size()%2==1)return 0;
            if(origin==-1)origin=i;
            if(getFather(i)!=getFather(origin))return 0;
            sort(adj[i].begin(),adj[i].end());
        }
    path.clear();
    memset(vis,0,sizeof(vis));
    if(origin!=-1)dfs(origin);
    reverse(path.begin(),path.end());
    return 1;
}

int main()
{
    int x,y,z;
    while(scanf("%d%d",&x,&y)!=EOF)
    {
        if(x==0&&y==0)
            break;
        scanf("%d",&z);
        for(int i=0; i<maxn; i++)
            adj[i].clear();
        add(x,y,z);
        while(scanf("%d%d",&x,&y)!=EOF)
        {
            if(y==0&&x==0)
                break;
            scanf("%d",&z);
            add(x,y,z);
        }

        if(solve())
        {
            int i;
            for( i=0; i<path.size()-1; i++)
                printf("%d ",path[i]);
            printf("%d\n",path[i]);
        }
        else
            printf("Round trip does not exist.\n");
    }
    return 0;
}






 

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值