HDU 1072 Nightmare

                                       Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5208    Accepted Submission(s): 2596


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 


 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 


 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 


 

Sample Input
  
  
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 


 

Sample Output
  
  
4 -1 13
 


 

Author
Ignatius.L
 

解题思路:本题用广度优先思路解答,找到起点终点后,从起点开始进行广度优先搜索,直到搜索到终点,则所搜结束,搜索成功,若搜索完所有可行节点未到达终点,则搜索失败。
 

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define N 9
struct Node
{
    int x;
    int y;
    int tme;
    int step;
};
int cas,n,m;//案例个数、地图大小
int sx,sy,ex,ey;//起点、终点位置
int map[N][N];//地图存储
int mark[N][N];//路线标记
int dir[4][2]={{0,-1},{0,1},{1,0},{-1,0}};//四个方向
bool Overmap(int x,int y)//判断访问点是否在地图范围内
{
    if(x<0||x>=n||y<0||y>=m)
    return true;
    else
    return false;
}
int bfs()//广度优先搜索
{
    memset(mark,0,sizeof(mark)); //标记数组初始化
    queue<Node>Q; //定义队列用于搜索
    Node first,next;//节点
    first.x=sx;
    first.y=sy;
    first.tme=6;    //起始时间
    first.step=0;
    Q.push(first);  //起始点入队
    mark[first.x][first.y]=6;
    while(!Q.empty())
    {
        first=Q.front();
        Q.pop();
        if(first.x==ex&&first.y==ey)    //在6分钟内成功走到终点
        {
            return first.step;
        }
        if(map[first.x][first.y]==4)    //走到加时点,时间恢复
        {

            first.tme=6;
            mark[first.x][first.y]=6;
        }
        for(int i=0;i<4;i++)//四个方向分别搜索
        {
            next.x=first.x+dir[i][0];
            next.y=first.y+dir[i][1];
            next.tme=first.tme-1;       //消耗时间
            next.step=first.step+1;     //增加步数
            if(Overmap(next.x,next.y)||map[next.x][next.y]==0||next.tme<=0)//该节点不能走,超出地图、该点为墙、时间用完
                continue;
            if(mark[next.x][next.y]<next.tme)//更新时间,节点入队
            {
                mark[next.x][next.y]=next.tme;
                Q.push(next);
            }
        }
    }
    return -1;
}
int main()
{
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        {
            scanf("%d",&map[i][j]);
            if(map[i][j]==2)//找到起点
            {
                sx=i;
                sy=j;
            }
            else if(map[i][j]==3)//找到终点
            {
               ex=i;
               ey=j;
            }
        }
        printf("%d\n",bfs());
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值