洛谷 池塘计数 floor-fill BFS 模板题

🍑 OJ专栏


🍑 P1596 Lake Counting

题面翻译

由于近期的降雨,雨水汇集在农民约翰的田地不同的地方。我们用一个 N × M ( 1 ≤ N ≤ 100 , 1 ≤ M ≤ 100 ) N\times M(1\leq N\leq 100, 1\leq M\leq 100) N×M(1N100,1M100) 的网格图表示。每个网格中有水(W) 或是旱地(.)。一个网格与其周围的八个网格相连,而一组相连的网格视为一个水坑。约翰想弄清楚他的田地已经形成了多少水坑。给出约翰田地的示意图,确定当中有多少水坑。

输入第 1 1 1 行:两个空格隔开的整数: N N N M M M

2 2 2 行到第 N + 1 N+1 N+1 行:每行 M M M 个字符,每个字符是 W.,它们表示网格图中的一排。字符之间没有空格。

输出一行,表示水坑的数量。

题目描述

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John’s field, determine how many ponds he has.

输入格式

Line 1: Two space-separated integers: N and M * Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

输出格式

Line 1: The number of ponds in Farmer John’s field.

样例 #1

样例输入 #1

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

样例输出 #1

3

提示

OUTPUT DETAILS: There are three ponds: one in the upper left, one in the lower left, and one along the right side.


🍑 模板题

import java.util.*;


class Main{
    static int N = 110,n,m;
    static char[][] g = new char[N][N];
    static boolean[][] st = new boolean[N][N];
    static Node[] q = new Node[N*N];// 队列最多有N*N个点
    // 点类
    static class Node{
        int x;
        int y;
        public Node(int x,int y)
        {
            this.x = x;
            this.y = y;
        }
    }
    // sx,sy 是起点的坐标
    static void bfs(int sx,int sy)
    {
        st[sx][sy] = true;//标记地点
        q[0] = new Node(sx,sy);
        int hh = 0;
        int tt = 0;
        
        while(hh <= tt)
        {
            Node t = q[hh++];//队首出列
            int x = t.x;
            int y = t.y;
            
            for(int xx = x-1; xx <= x+1; xx++)
                for(int yy = y-1; yy <= y +1; yy++)
                {
                    if(xx >= n || xx < 0 || yy >= m || yy < 0)
                        continue;
                    //{xx,yy} == {x,y} 的情况已经遍历过了,无需特殊处理
                    if(st[xx][yy]  || g[xx][yy] == '.')
                        continue;
                        
                    st[xx][yy] = true;
                    q[++tt] = new Node(xx,yy);//从队尾入列
                    
                    
                }
            
        }
        
 
    }
    
    
    public static void main(String[] args)
    {
        Scanner sc = new Scanner(System.in);
        n = sc.nextInt();
        m = sc.nextInt();
        sc.nextLine();
        for(int i = 0; i < n; i++)
        {
            String s = sc.nextLine();
            for(int j = 0; j < m; j++)
                g[i][j] = s.charAt(j);
        }   
        int cnt = 0;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < m; j++)
                if(!st[i][j] && g[i][j] == 'W')
                {
                    bfs(i,j);//找到一块池塘,就把它所在的连通块去掉
                    cnt++;
                }
                
        System.out.println(cnt);
    }
    
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值