杭电—1865 大数斐波那契数列 光棍的yy

1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4993    Accepted Submission(s): 1852


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2 8
 

Author
z.jt
 
解题思路:
这道题开始时代码都看不懂是什么意思!!!经过向学长询问和自己的揣摩,才慢慢搞懂这道题的意思。
首先就是二维数组的使用,a[i][j]表示的是第i个数的第j位,用倒序,例如,a【7】【0】==1,a【7】【1】==2;
然后要注意判断结果的有几位数!
AC代码:
#include<stdio.h>
#include<string.h>
int a[205][102];
void count()
 {
   int i,j,p,q;
   memset(a,0,sizeof(a));
   a[1][0]=1;a[2][0]=2;
   for(i=3;i<203;i++)
   {
    p=0;q=0;
    for(j=0;j<=100;j++)
     {
       p=a[i-1][j]+a[i-2][j]+q;
       a[i][j]=p%10;
       q=p/10;
     }
   }
 }
int main()
 {
   count();
   int n,i,j,len;
   char s[205];
   scanf("%d",&n);
   while(n--)
   {
     getchar();
     scanf("%s",s);
     len=strlen(s);
     for(i=100;i>=0;i--)
      {
        if(a[len][i]!=0)
        break;
      }
     for(j=i;j>=0;j--)
    { 
      printf("%d",a[len][j]);
    }
     printf("\n");
   }

 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值