习题 ct6_1: 循环移位☆



[mytable=ct6_1: 循环移位☆]题目描述:
给你一个字符串"abcdefg",循环左移两位得到"cdefgab",
循环右移两位得到"fgabcde"


输入:
多组测试数据,每组一行,第一个是int范围内的整数n,
表示要右移的位数,如果n是负数则表示要左移。接着后面
是一个串长小于10000000的字符串。
最后遇到EOF标志的时候结束。


输出:
输出移位后的字符串


样例输入:
2 abcdefg
-2 abcdefg


样例输出:
fgabcde
cdefgab


难度:for beginner[/mytable]


// ct6_1.cpp : Defines the entry point for the console application.
//

#include "stdafx.h"
#include "stdio.h"
#include  "string.h"


int main(int argc, char* argv[])
{
	char str[100];
	int  pos, i, length;
    while( scanf("%d%s", &pos, str) != EOF)
	{
		length = strlen(str);
		if (pos > 0)
		{
			if (pos % length == 0) { printf("%s\n", str); continue;}
			for (i= length-pos; i<=length-1; i++ )
			{
				printf("%c",str[i]);
			}
			for (i= 0; i<=length-pos-1; i++ )
			{
				printf("%c",str[i]);
			}
			continue;			
		}
		else if (pos < 0)
		{
			pos = -1 * pos;
			if (pos % length == 0) { printf("%s\n", str); continue;}
			for (i= pos; i<=length-1; i++ )
			{
				printf("%c",str[i]);
			}
			for (i= 0; i<=pos-1; i++ )
			{
				printf("%c",str[i]);
			}
			continue;
		}
		else 
		{
			printf("%s\n", str); 
			continue;
		}
	
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值