[sicily]1209. Sequence Sum Possibi

1209. Sequence Sum Possibi

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Most positive integers may be written as a sum of a sequence of at least two consecutive positive integers. For instance,

6 = 1 + 2 + 3 
9 = 5 + 4 = 2 + 3 + 4

but 8 cannot be so written.

Write a program which will compute how many different ways an input number may be written as a sum of a sequence of at least two consecutive positive integers. 

Input

The first line of input will contain the number of problem instances N on a line by itself, (1<=N<=1000) . This will be followed by N lines, one for each problem instance. Each problem line will have the problem number, a single space and the number to be written as a sequence of consecutive positive integers. The second number will be less than 2^31 (so will fit in a 32-bit integer). 

Output

The output for each problem instance will be a single line containing the problem number, a single space and the number of ways the input number can be written as a sequence of consecutive positive integers. 

Sample Input

7 
1 6 
2 9 
3 8 
4 1800 
5 987654321 
6 987654323 
7 987654325

Sample Output

1 1 
2 2 
3 0 
4 8 
5 17 
6 1 
7 23

简单的数论题。给定一个数,找出有多少组连续数字之和为该数。利用等差数列公式,枚举项数。设有 i 项,为 l,l+1,l+2....l+i-1; 则,(2l + i-1 ) * i = 2n ; 即:2l*i + (i-1)*i = 2n,由于 l 大于0的整数,则,可判断出 i 的范围以及 i 能否成为项数的条件。具体代码如下:


#include <iostream>
using namespace std;

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int count = 0;
        int index, num;
        cin>>index>>num;
        for(int i=2; i*i-i < 2*num; i++)
        {
            if( (2*num - i*(i-1)) % (2*i) == 0)
                count++;
        }
        cout<<index<<" "<<count<<endl;
        
    } 
    //system("pause");
    return 0;
}                                 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值