Ant on a Chessboard

 One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)

  At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left¡­in a word, the path was like a snake.

  For example, her first 25 seconds went like this:

  ( the numbers in the grids stands for the time when she went into the grids)

 

25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

5

4

3

2

1

 

1          2          3           4           5

At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).

Your task is to decide where she was at a given time.

(you can assume that M is large enough)

 

 

Input

  Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.

 

 

Output

  For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.

 

 

Sample Input

8

20

25

0

 

 

Sample Output

2 3

5 4

1 5



题目:给出一个数,找出对应的坐标

解法:一开始想填数,后来发现数据过大肯定超时,就改成找规律了,有点难找。先把给的数开根后向上取整就知道他在哪个对角线上的点A的附近,然后根据这个点A的所在坐标奇偶以及与A与我们需要找的数进行数值大小的比较可以知道我们这个点是在A的左边还是下边


#include <iostream>
#include <cmath>

using namespace std;

int cal(int n){
	int res=1;
	for(int i=1; i <= n; i++){
		res+=2*(i-1);
	}
	return res;
}//找出对角线上某一点的值 

int main()
{
	long long n;
	while(cin >> n){
		if(n==0) break; 
		int num=ceil(sqrt(double(n))); 
		int x=num,y=num;
		int duijiao=cal(num);
		//cout << num << " " << duijiao << endl;
		if(num%2==1){
			if(n==duijiao){
				cout << x << " " << y << endl;
			}
			else if(n<duijiao){
				cout << x << " " << y-(duijiao-n) << endl;
			}
			else if(n>duijiao){
				cout << x-(n-duijiao) << " " << y << endl;
			}
		}
		else{
			if(n==duijiao){
				cout << x << " " << y << endl;
			}
			else if(n>duijiao){
				cout << x << " " << y-(n-duijiao) << endl;
			}
			else if(n<duijiao){
				cout << x-(duijiao-n) << " " << y << endl;
			}
		}
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值