HDU problem 5635 LCP Array【思维】

LCP Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1532    Accepted Submission(s): 468


Problem Description
Peter has a string  s=s1s2...sn , let  suffi=sisi+1...sn  be the suffix start with  i -th character of  s . Peter knows the lcp (longest common prefix) of each two adjacent suffixes which denotes as  ai=lcp(suffi,suffi+1)(1i<n ).

Given the lcp array, Peter wants to know how many strings containing lowercase English letters only will satisfy the lcp array. The answer may be too large, just print it modulo  109+7 .
 

Input
There are multiple test cases. The first line of input contains an integer  T  indicating the number of test cases. For each test case:

The first line contains an integer  n  ( 2n105)  -- the length of the string. The second line contains  n1  integers:  a1,a2,...,an1   (0ain) .

The sum of values of  n  in all test cases doesn't exceed  106 .
 

Output
For each test case output one integer denoting the answer. The answer must be printed modulo  109+7 .
 

Sample Input
  
  
3 3 0 0 4 3 2 1 3 1 2
 

Sample Output
  
  
16250 26 0
 

Source
 

Recommend
题意: 给你一个含有N-1个元素的数组,数组对应一个长度为N的字符串,数组中的第i个数的含义为字符串中第i个开头的和第i+1个开头的字符串的子串的最大公共前缀的长度,现在让你推算数这个字符串有多少种情况。
先把数组处理下,对于i个长度为0的子串,它的颜色和他的后面的元素的字母不相同,标记下。如果长度不为0,它的首字母必定和下个字母相同,然后利用最大长度检查剩下的是否也相同,要是不相同,则这组数据出错了。
利用记录的字符串的信息扫一下,如果某个位置的字符和它的后面的相同,则他的情况和后面支付的一样,否则它有25种可能性。
#include <map>
#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <iostream>
#include <stack>
#include <cmath>
#include <string>
#include <vector>
#include <cstdlib>
//#include <bits/stdc++.h>
//#define LOACL
#define space " "
using namespace std;
typedef long long LL;
typedef __int64 Int;
typedef pair<int, int> PAI;
const int INF = 0x3f3f3f3f;
const double ESP = 1e-5;
const double PI = acos(-1.0);
const int MOD = 1e9 + 7;
const int MAXN = 1e5 + 10;
int ar[MAXN], clor[MAXN];
int main() {
    int T, N;
    scanf("%d", &T);
    while (T--) {
        memset(clor, 0, sizeof(clor));
        scanf("%d", &N);
        for (int i = 0; i < N - 1; i++) scanf("%d", &ar[i]);
        clor[N - 1] = 1;
        int cnt = 2;
        bool flag = false;
        for (int i = N - 2; i >= 0; i--) {
            if (ar[i] != 0) {
                clor[i] = clor[i + 1];
                for (int j = 1; j <= ar[i]; j++) {
                    if (clor[i] != clor[i + j]) {flag = true; break;}
                }
                if (clor[i + ar[i] + 1] == clor[i]) {flag = true; break;}
            }
            else clor[i] = cnt++;
            if (flag) break;
        }
        Int ans = 26;
       // cout << "数据发生错误: " << flag <<endl;
        bool change = false;
        int temp = clor[N - 1];
        //for (int i = 0; i < N; i++) printf("第i个字母应该是%d\n", clor[i]);
        for (int i = N - 2; i >= 0; i--) {
            if (clor[i] != temp) {
                ans *= 25;  temp = clor[i];
                ans %= MOD;
            }
        }
        if (flag) printf("%d\n", 0);
        else printf("%I64d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值