POJ 2155 Matrix 树状数组

Matrix




Problem Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 
 

Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. <br> <br>The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. <br>
 

Output
For each querying output one line, which has an integer representing A[x, y]. <br> <br>There is a blank line between every two continuous test cases. <br>
 

Sample Input
  
  
1 2 10 C 2 1 2 2 Q 2 2 C 2 1 2 1 Q 1 1 C 1 1 2 1 C 1 2 1 2 C 1 1 2 2 Q 1 1 C 1 1 2 1 Q 2 1
 

Sample Output
  
  
1 0 0 1
 

//题意:有个N*N的矩阵,每个点的值要么是0,要么是1,每个点一开始的初始值为0。现在有2种操作:“C”:要输入x1,y1,x2,y2(x2>x1 , y2>y1),把以(x1,y1),(x2,y2)为对角线顶点的那个矩形里的值改变(若原来是1,变为0;原来是0,变为1)。“Q”:输入x,y,要求这点的值是0还是1。

//思路:最先想到的应该是定义一个map二维数组,在根据要求去改变map里的值,但只要稍微想一下就知道这么暴力(N*N)绝逼TLE,于是就考虑怎样高效地改变一个区间里的值,那么显然树状数组(复杂度N*logN)是一个好方法。

然后这里还有一个小技巧,每次1->0,0->1很麻烦,其实只要每个点要改变的时候都+1就行了,最后要计算的时候,如果是奇数就是1,偶数就是0。

还有“C”的时候,x2,y2都要+1(即(x2+1,y2+1)),这是考虑到顶点的情况,自己画个图感受下就很清楚了。

(搞清楚树状数组推荐博客:http://blog.csdn.net/int64ago/article/details/7429868)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <cstdlib>
#include <algorithm>
using namespace std;

const int MAX = 1010;

int n, num;
int c[MAX][MAX];

int lowbit(int x)
{
	return x&(-x);
}

void add(int x,int y, int val)
{
	for (int i = x; i <= n; i += lowbit(i))
	{
		for (int j = y; j <= n; j += lowbit(j))
		{
			c[i][j] += val;
		}
	}
}

int sum(int x, int y)
{
	int sum = 0;
	for (int i = x; i > 0; i -= lowbit(i))
	{
		for (int j = y; j > 0; j -= lowbit(j))
		{
			sum += c[i][j];
		}
	}
	return sum;
}

int main()
{
	int i, j, k;
	int T;
	cin >> T;
	while (T--)
	{
		char a;
		int x1, y1, x2, y2;
		scanf("%d%d", &n, &num);
		getchar();
		memset(c, 0, sizeof(c));
		for (i = 1; i <= num; i++)
		{
			scanf("%c", &a);
			if (a == 'C')
			{
				scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
				//用树状数组只要传入4个角,遍历的复杂度是NlogN
				//暴搜的话是N平方,肯定TLE
				//自己画个图更好理解一点
				//x2,y2都+1是为了考虑4个顶点的情况
				//改变的每个坐标的值不用真的从0->1,1->0
				//每次都+1就好了,如果是偶数,表明这点就是0;奇数的话就是1;
				add(x2 + 1, y2 + 1, 1);
				add(x1, y1, 1);
				add(x1, y2 + 1, 1);
				add(x2 + 1, y1, 1);
			}
			else if (a == 'Q')
			{
				scanf("%d%d", &x1, &y1);
				int temp = sum(x1, y1) % 2;
				printf("%d\n", temp);
			}
			getchar();
		}
		if (T != 0)
			printf("\n");
	}
	return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值