poj3252 数位dp(所有比n小的二进制位0的个数不少于1的个数)记忆化搜索

15 篇文章 0 订阅

http://poj.org/problem?id=3252

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6
/**
poj 3252   数位dp(所有比n小的二进制位0的个数不少于1的个数)记忆化搜索
题目大意:求出区间内二进制表示是0的个数不小于1的个数的数的个数
解题思路:用记忆化搜索dfs(len,num0,num1,flag,first)len表示二进制的位置,num0表示0的个数,flag标记是不是访问到上限,
           first表示第一个1的位置,对于每个这样的位置开始以后看做一个次二进制数
           http://blog.csdn.net/libin56842/article/details/10037607
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int dp[50][50][50],n,m,bit[50];

int dfs(int len,int num0,int num1,int flag,int first)
{
    if(len<0)return num0>=num1;
    if(flag==0&&dp[len][num0][num1]!=-1)return dp[len][num0][num1];
    int ans=0;
    int end=flag?bit[len]:1;
    for(int i=0; i<=end; i++)
    {
        int t=first&&(i==0);
        ans+=dfs(len-1,t?0:num0+(i==0),t?0:num1+(i==1),flag&&i==end,t);
    }
    if(flag==0)dp[len][num0][num1]=ans;
    return ans;
}

int solve(int n)
{
    int len=0;
    while(n)
    {
        bit[len++]=n%2;
        n>>=1;
    }
    return dfs(len-1,0,0,1,1);
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,-1,sizeof(dp));
        printf("%d\n",solve(m)-solve(n-1));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值