Subsequence poj3061(尺取法)

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13114 Accepted: 5537

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题目分析:尺取法的标准模板题。一般对于一个数列求其中某一范围的特性的时候可以使用。这题有负数的话就是动规了。。

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxx=100000+50;
int cun[maxx];
int fir,sec,sum;
int main(){
int n,s,t;
cin>>t;
while(t--)
{
 fir=sec=sum=0;
 cin>>n>>s;
 for(int i=1;i<=n;i++)cin>>cun[i];
 int res=maxx;
while(sec<=n)
{
    if(sum<s)sec++,sum+=cun[sec];
    else if(sum>=s){
            //cout<<sec<<"        "<<fir<<endl;
        res=min(res,sec-fir);
       sum-=cun[fir++];
    }
}
if(res>=n)cout<<0<<endl;
else cout<<res+1<<endl;
}
return 0;}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值