ACM-搜索之FireNet——hdu1045

展开搜索专题,恩,先来一道简单的回溯搜索。

回溯算法也叫试探法,它是一种系统地搜索问题的解的方法。

用回溯算法解决问题的一般步骤:

 1 针对所给问题,定义问题的解空间,它至少包含问题的一个(最优)解。

     2 确定易于搜索的解空间结构,使得能用回溯法方便地搜索整个解空间

         3 以深度优先的方式搜索解空间,并且在搜索过程中用剪枝函数避免无效搜索。

问题的解空间通常是在搜索问题解的过程中动态产生的,这是回溯算法的一个重要特性。

回溯算法的基本思想是:从一条路往前走,能进则进,不能进则退回来,换一条路再试。

典型的回溯题目就是八皇后问题,我之前发过一篇N皇后的题目:

http://blog.csdn.net/lttree/article/details/20796403

接下来这道题目,是我看度娘上说是回溯搜索,恩,因为数据量不大,基本不需要剪枝啊=。=

题目可直接看HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1045

Fire Net
Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0


Sample Output
5
1
5
2
4


题意应该很清楚,就是给你一个地图,地图上有一些墙,向地图内放炮台,不要让两个炮台能互相射击到对方,

当然中间有墙就可以阻隔他们。求最多能放多少炮台。

这道题,刚开始我按n皇后那道题思路解了,只考虑每行放一个,结果测试用例都没过。。。

后来再看发现理解错了,改了改就AC了。

如果放炮台,在该点设置一个炮台标记,

判断某一点是否可以放炮台,就是从该点向四个方向找,碰到墙停止,碰到别的炮台就返回0,表示该点不能放炮台。

题目不是很难,练一下基础的搜索。


#include <iostream>
using namespace std;
int n,sum;
char map[5][5];

// 判断该点可否放炮台
bool judge(int line,int list)
{
    if(map[line][list]=='X')    return 0;
    int i;
    for(i=line;i>=0;--i)
    {
        if(map[i][list]=='X')   break;
        if(map[i][list]=='S')   return 0;
    }
    for(i=line;i<n;++i)
    {
        if(map[i][list]=='X')   break;
        if(map[i][list]=='S')   return 0;
    }
    for(i=list;i>=0;--i)
    {
        if(map[line][i]=='X')   break;
        if(map[line][i]=='S')   return 0;
    }
    for(i=list;i<n;++i)
    {
        if(map[line][i]=='X')   break;
        if(map[line][i]=='S')   return 0;
    }
    return 1;
}

// 回溯吧~
void recall(int line,int list,int num)
{
    if(line==n)
    {
        sum=sum>num?sum:num;
        return;
    }

    int i;
    for(i=list;i<n;++i)
    {
        if(judge(line,i))
        {
            map[line][i]='S';
            recall(line,i,num+1);
            map[line][i]='.';
        }
    }
    recall(line+1,0,num);
}

int main()
{
    int i,j;
    while(cin>>n)
    {
        if(!n)  break;

        for(i=0;i<n;++i)
            for(j=0;j<n;++j)
                cin>>map[i][j];

        sum=0;
        recall(0,0,0);
        cout<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值