ACM-BFS之Nightmare——hdu1072

Nightmare

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1072

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input
3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1

Sample Output
4
-1

13


NightMare  就是在一个地宫中从入口到出口,2为入口,3为出口,0为墙,1为路。

当从入口离开,地宫倒计时6秒坍塌,地图中有一些装置可以重置坍塌时间,(不是坍塌时间晚6秒,而是重新更新到6秒,继续倒计时)

最终输出到出口时,花费的总时间。

有几点:

①当你踏上出口时,倒计时刚好归0,则无法出去。同理,倒计时归0时,到达重置时间点也是不可以的。

②如果出不去 输出-1.

③重置时间装置可以重复触发。


这道题目关键就在于它的VIS数组,因为里面的路可以多次访问,不能走一次都归0。

当碰到重置时间装置,使vis数组全为0,也是行不通的,因为队列里有一些其他的点的访问会影响到。

仔细,想想,什么时候不需要再次走这条路了呢?

当然是当你到达这个点时,和之前到达此点所剩余时间比较,

如果你后到达这个点剩余时间小于之前到达这个点剩余时间,那就不需要走这条路了。

剩余时间,当然是地宫坍塌的时间,如此设置vis数组,bfs就可以过了。


#include <iostream>
#include <queue>
#include <string.h>
using namespace std;

char mapp[9][9];
int vis[9][9];
int dis[4][2]={-1,0,1,0,0,-1,0,1};
int n,m,f_x,f_y;
// 坐标结构体,存储总时间,和炸弹倒计时
struct Coordinate
{
	int x,y,to_time,now_time;
};

// 判断越界等状况
bool judge(int x,int y)
{
	if(x<0 || y<0 || x>=n || y>=m)	return 0;
	if(mapp[x][y]=='0')	return 0;
	return 1;
}

int bfs(int x,int y)
{
	int i;
	queue <Coordinate> q;
	Coordinate a,b;
	memset(vis,0,sizeof(vis));

	// 对队列与起点的初始化
	vis[x][y]=6;
	a.x=x;
	a.y=y;
	a.to_time=0;
	a.now_time=6;
	q.push(a);

	while(!q.empty())
	{
		a=q.front();
		q.pop();

		if(a.x==f_x && a.y==f_y)	return a.to_time;

		for(i=0;i<4;++i)
		{
			b.x=a.x+dis[i][0];
			b.y=a.y+dis[i][1];

			if(judge(b.x,b.y))
			{

				//如果踩到重置时间
				if(mapp[b.x][b.y]=='4')
				{
				    if(a.now_time==1)   continue;
					b.to_time=a.to_time+1;
					b.now_time=6;
                    // 判断后到达的此点剩余时间是否 大于 之前到达这个点剩余时间
                    if(b.now_time==0 || b.now_time<=vis[b.x][b.y])	continue;
                    vis[b.x][b.y]=b.now_time;
                    q.push(b);
				}
				else
				{
					b.to_time=a.to_time+1;
					b.now_time=a.now_time-1;
					// 判断后到达的此点剩余时间是否 大于 之前到达这个点剩余时间
                    if(b.now_time==0 || b.now_time<=vis[b.x][b.y])	continue;
                    // 当然也要更新时间
                    vis[b.x][b.y]=b.now_time;
                    q.push(b);
				}
			}
		}
	}

	return -1;
}

int main()
{
	int total_case,i,j;
	int s_x,s_y;

	cin>>total_case;
	while(total_case--)
	{
		cin>>n>>m;
		// 输入时记录起点与终点坐标
		for(i=0;i<n;++i)
			for(j=0;j<m;++j)
			{
				cin>>mapp[i][j];
				if(mapp[i][j]=='2')	{s_x=i;s_y=j;}
				if(mapp[i][j]=='3')	{f_x=i;f_y=j;}
			}
		cout<<bfs(s_x,s_y)<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值