PTA:结构 通讯录的录入与显示

通讯录中的一条记录包含下述基本信息:朋友的姓名、出生日期、性别、固定电话号码、移动电话号码。
本题要求编写程序,录入N条记录,并且根据要求显示任意某条记录。

输入格式:

输入在第一行给出正整数N(≤10);随后N行,每行按照格式姓名 生日 性别 固话 手机给出一条记录。其中姓名是不超过10个字符、不包含空格的非空字符串;生日按yyyy/mm/dd的格式给出年月日;性别用M表示“男”、F表示“女”;固话手机均为不超过15位的连续数字,前面有可能出现+

在通讯录记录输入完成后,最后一行给出正整数K,并且随后给出K个整数,表示要查询的记录编号(从0到N−1顺序编号)。数字间以空格分隔。

输出格式:

对每一条要查询的记录编号,在一行中按照姓名 固话 手机 性别 生日的格式输出该记录。若要查询的记录不存在,则输出Not Found

输入样例:

3
Chris 1984/03/10 F +86181779452 13707010007
LaoLao 1967/11/30 F 057187951100 +8618618623333
QiaoLin 1980/01/01 M 84172333 10086
2 1 7

输出样例:

LaoLao 057187951100 +8618618623333 F 1967/11/30
Not Found

代码如下:

#include<stdio.h>
#include<string.h>
struct message
{
    char name[11];
    char birthday[11];
    char gender;
    char telephone[17];
    char phone[17];
};
int main()
{
    int n;
    scanf("%d",&n);
    struct message friend[n];
    for(int i=0;i<n;i++)
    {
        scanf("%s %s %c %s %s",friend[i].name,friend[i].birthday,&friend[i].gender,friend[i].telephone,friend[i].phone);
    }
    int K;
    scanf("%d",&K);
    int choices[10];
    for(int i=0;i<K;i++)
    {
        scanf("%d",&choices[i]);
    }
    for(int i=0;i<K;i++)
    {
        if(choices[i]>=n||choices[i]<0)
        {
            printf("Not Found\n");
        }else{
            printf("%s %s %s %c %s\n",friend[choices[i]].name,friend[choices[i]].telephone,friend[choices[i]].phone,friend[choices[i]].gender,friend[choices[i]].birthday);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值