@Override must override a superclass method 解决方法

使用Eclipse开发Java项目时,在@Override 出现以下错误:
The method * of type * must override a superclass method
是因为你的Compiler是jdk5,(5不支持@Override等形式的批注)只要把它改为6就可以了。

方法:右击项目 选择Properties , 选择Java Compiler,将Compiler compliance level修改为1.7即可
这里写图片描述

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/ly_linyuan/article/details/79961145
文章标签: java
个人分类: java
上一篇Project facet Java version 1.8 is not supported解决方法
下一篇csdn删除自己上传的资源
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭