11-散列1 电话聊天狂人 (25分)

11-散列1 电话聊天狂人   (25分)

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数NN\le 10^5105),为通话记录条数。随后NN行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

13588625832 3

参照数据结构学习与实验指导


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>

#define MAXS 11
#define MAXD 5

typedef struct HashEntry *List;
struct HashEntry{
	char PhoneNo[MAXS+1];
	int Cnt;
	List Next;
};

struct HashTb1{
	int TableSize;
	List TheLists;
};
typedef struct HashTb1 *HashTable;

int NextPrime(int N){
	int i;
	if(!(N%2))N++;
	for(;;N+=2){
		for(i=(int)sqrt(N);i>2;i--){
			if(!(N%i))break;
		}
		if(i==2)break;
	}
	return N;
}

HashTable InitializeTable(int N){
	int i;
	HashTable H=(HashTable)malloc(sizeof(struct HashTb1));
	H->TableSize=NextPrime(N);
	H->TheLists=(List)malloc(sizeof(struct HashEntry)*H->TableSize);
	for(i=0;i<H->TableSize;i++){
		H->TheLists[i].Cnt=0;
		H->TheLists[i].Next=NULL;
		H->TheLists[i].PhoneNo[0]='\0';
	}
	return H;
}

int Hash(int Key,int P){
	return Key%P;
}

void InsertAndCount(char *Key,HashTable H){
	List Ptr,NewCell,L;
	L=&(H->TheLists[Hash(atoi(Key+6),H->TableSize)]);
	Ptr=L->Next;
	while(Ptr&&strcmp(Ptr->PhoneNo,Key)){
		Ptr=Ptr->Next;
	}
	if(Ptr){
		Ptr->Cnt++;	
	}
	else{
		NewCell=(List)malloc(sizeof(struct HashEntry));
		strcpy(NewCell->PhoneNo,Key);
		NewCell->Cnt=1;
		NewCell->Next=L->Next;
		L->Next=NewCell; 
	}
}

void Output(HashTable H){
	int i,MaxCnt,PCnt;
	List Ptr;
	char MinPhone[MAXS+1];
	MaxCnt=PCnt=0;
	MinPhone[0]='\0';
	for(i=0;i<H->TableSize;i++){
		Ptr=H->TheLists[i].Next;
		while(Ptr){
			if(Ptr->Cnt>MaxCnt){
				MaxCnt=Ptr->Cnt;
				strcpy(MinPhone,Ptr->PhoneNo);
				PCnt=1;
			}
			else if(Ptr->Cnt==MaxCnt){
				PCnt++;
				if(strcmp(MinPhone,Ptr->PhoneNo)>0){
					strcpy(MinPhone,Ptr->PhoneNo);
				}
			}
			Ptr=Ptr->Next;
		}
	}
	printf("%s %d",MinPhone,MaxCnt);
	if(PCnt>1){
		printf(" %d",PCnt);
	}
//	printf("\n");
}
int main(){
	int N,i;
	char Key[MAXS+1];
	HashTable H;
	scanf("%d",&N);
	H=InitializeTable(N);
	for(i=0;i<N;i++){
		scanf("%s",Key);
		InsertAndCount(Key,H);
		scanf("%s",Key);
		InsertAndCount(Key,H);
	}
	Output(H);	
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值