1073. Scientific Notation (20)

1073. Scientific Notation (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9]"."[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input file contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros,

Sample Input 1:
+1.23400E-03
Sample Output 1:
0.00123400
Sample Input 2:
-1.2E+10
Sample Output 2:
-12000000000
参照算法笔记P69
#include<stdio.h>
#include<string.h>
char s[10010];
int main(){
	int i,len;
	gets(s);
	len=strlen(s);
	if(s[0]=='-'){
		printf("-");
	}
	int indexE;
	for(i=0;i<len;i++){
		if(s[i]=='E'){
			indexE=i;break;//找到E的下标 
		} 
	}
	int e=0;
	for(i=indexE+2;i<len;i++){//计算指数 
		e=e*10+s[i]-'0';
	}
	if(e==0){//指数为0 ,测试点貌似没有这种情况... 
		for(i=1;i<indexE;i++){
			printf("%c",s[i]);
		}
	}
	else{
		if(s[indexE+1]=='-'){ 
			printf("0.");
			for(i=0;i<e-1;i++){//0.后面0的个数为 e-1(-1是因为0.占了一个) 
				printf("0");
			}
			for(i=1;i<indexE;i++){//从1开始到E-1截止的非小数点 
				if(s[i]!='.'){
					printf("%c",s[i]);
				}
			}
		}
		else{
			int length=indexE-3;//-1.2E+10 从小数点开始到E有几个数 
			if(e>=length){//指数够大,无需输出小数点 
				for(i=1;i<indexE;i++){
					if(s[i]!='.'){
						printf("%c",s[i]);
					}
				}
				for(i=0;i<e-length;i++){//剩余后缀0 
					printf("0");
				}
			}
			else{// 指数不够大,需输出小数点
				for(i=1;i<3+e;i++){//-1.2734E+03 输出-1273.4 
					if(s[i]!='.'){
						printf("%c",s[i]);
					}
				}
				printf(".");
				for(;i<indexE;i++){
					printf("%c",s[i]);
				}
			}
		}
	}	 
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值